summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorhumanitiesNerd <catonano@gmail.com>2016-06-02 21:53:12 +0200
committerAlex Kost <alezost@gmail.com>2016-06-05 12:03:43 +0300
commitf9be43660f6dad9b52f7349bc13803e8edb04004 (patch)
tree88b4430258ee67466eaa3e5b0f143cd923d86059 /gnu/packages
parent555d02e739e3c91ccad67d83b691380a545e794d (diff)
downloadguix-patches-f9be43660f6dad9b52f7349bc13803e8edb04004.tar
guix-patches-f9be43660f6dad9b52f7349bc13803e8edb04004.tar.gz
gnu: Add emacs-cider.
* gnu/packages/emacs.scm (emacs-cider): New variable. Signed-off-by: Alex Kost <alezost@gmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 07b4255adb..1f1d201a32 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -2053,3 +2053,39 @@ considered to be its successor. Helm sets out to clean up the legacy code in
@code{anything.el} and provide a cleaner, leaner and more modular tool, that's
not tied in the trap of backward compatibility.")
(license license:gpl3+)))
+
+(define-public emacs-cider
+ (package
+ (name "emacs-cider")
+ (version "0.12.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/clojure-emacs/cider/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "00qzbfjy3w6bcnki7gw0clmi0cc5yqjdrcyhgv4ymijjs79h9p5s"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-clojure-mode" ,emacs-clojure-mode)
+ ("emacs-spinner" ,emacs-spinner)
+ ("emacs-pkg-info" ,emacs-pkg-info)
+ ("emacs-queue" ,emacs-queue)
+ ("emacs-seq" ,emacs-seq)))
+ (home-page "https://cider.readthedocs.org/")
+ (synopsis "Clojure development environment for Emacs")
+ (description
+ "CIDER (Clojure Interactive Development Environment that Rocks) aims to
+provide an interactive development experience similar to the one you'd get
+when programming in Emacs Lisp, Common Lisp (with SLIME or Sly), Scheme (with
+Geiser) and Smalltalk.
+
+CIDER is the successor to the now deprecated combination of using SLIME +
+swank-clojure for Clojure development.
+
+There are plenty of differences between CIDER and SLIME, but the core ideas
+are pretty much the same (and SLIME served as the principle inspiration for
+CIDER).")
+ (license license:gpl3+)))