summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2022-05-18 14:11:20 -0400
committerLudovic Courtès <ludo@gnu.org>2022-05-22 01:07:56 +0200
commitf8e080691d95fd3b056de1808c51b702f3683979 (patch)
treeac7dc33be969c6e7d8051120dcef97d738a2c1b6 /gnu/packages
parent1b8d1f7d48f1d4cfb44fe1163e76609c8ee8e722 (diff)
downloadguix-patches-f8e080691d95fd3b056de1808c51b702f3683979.tar
guix-patches-f8e080691d95fd3b056de1808c51b702f3683979.tar.gz
gnu: Add elm-terezka-intervals.
* gnu/packages/elm.scm (elm-terezka-intervals): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/elm.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/elm.scm b/gnu/packages/elm.scm
index a9b24b3b00..cf203addd5 100644
--- a/gnu/packages/elm.scm
+++ b/gnu/packages/elm.scm
@@ -729,3 +729,34 @@ formatting dates and times. It uses Elm's type system instead of format
strings, which makes formatting code more readable and can catch some errors
at compile time.")
(license license:bsd-3)))
+
+(define-public elm-terezka-intervals
+ (package
+ (name "elm-terezka-intervals")
+ (version "2.0.1")
+ (source
+ (elm-package-origin
+ "terezka/intervals"
+ version
+ (base32 "0h3im58sa6awyppch1v8ppcrzwc5h48yn45crx98m8zs4isx91lj")))
+ (build-system elm-build-system)
+ (propagated-inputs
+ (list elm-ryannhg-date-format
+ elm-myrho-elm-round
+ elm-justinmimbs-time-extra
+ elm-time
+ elm-svg
+ elm-json
+ elm-html
+ elm-core
+ elm-danhandrea-elm-time-extra))
+ (inputs (list elm-explorations-test))
+ (home-page "https://package.elm-lang.org/packages/terezka/intervals/2.0.1")
+ (synopsis "Produce nice intervals for Elm charts")
+ (description
+ "This package provides an Elm library for producing nice intervals for
+charts. It's useful in combination with @code{terezka/elm-charts}. When I
+say ``nice'', I just mean that I try to calculate intervals which begin with
+10, 5, 3, 2, or 1 (adjusted to magnitude, of course!). For dates, I try to
+hit whole days, weeks, and months or hours, minutes, and seconds.")
+ (license license:bsd-3)))