summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-03-31 22:43:01 +0200
committerLudovic Courtès <ludo@gnu.org>2015-03-31 22:43:01 +0200
commitf8503e2b2588391c4c0f8d8dd11ef3e9449a2884 (patch)
tree08e6a9f242ff364e7e3c08d939bb2250603f104d /gnu/packages
parent023dd28a303961cbf2848f13d3156c162d5e76c0 (diff)
downloadguix-patches-f8503e2b2588391c4c0f8d8dd11ef3e9449a2884.tar
guix-patches-f8503e2b2588391c4c0f8d8dd11ef3e9449a2884.tar.gz
utils: 'modify-phases' no longer introduces quotes.
Suggested by Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>. * guix/build/utils.scm (%modify-phases): Remove quotes. * guix/build/cmake-build-system.scm (%standard-phases): Adjust accordingly. * guix/build/glib-or-gtk-build-system.scm (%standard-phases): Likewise. * guix/build/gnu-dist.scm (%dist-phases): Likewise. * guix/build/perl-build-system.scm (%standard-phases): Likewise. * guix/build/python-build-system.scm (%standard-phases): Likewise. * guix/build/ruby-build-system.scm (%standard-phases): Likewise. * guix/build/waf-build-system.scm (%standard-phases): Likewise. * gnu/packages/bash.scm, gnu/packages/code.scm, gnu/packages/gl.scm, gnu/packages/gnome.scm, gnu/packages/graphics.scm, gnu/packages/image.scm, gnu/packages/key-mon.scm, gnu/packages/ocr.scm, gnu/packages/plotutils.scm, gnu/packages/search.scm, gnu/packages/video.scm: Likewise.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bash.scm4
-rw-r--r--gnu/packages/code.scm8
-rw-r--r--gnu/packages/gl.scm12
-rw-r--r--gnu/packages/gnome.scm4
-rw-r--r--gnu/packages/graphics.scm4
-rw-r--r--gnu/packages/image.scm4
-rw-r--r--gnu/packages/key-mon.scm2
-rw-r--r--gnu/packages/ocr.scm2
-rw-r--r--gnu/packages/plotutils.scm6
-rw-r--r--gnu/packages/search.scm6
-rw-r--r--gnu/packages/video.scm6
11 files changed, 29 insertions, 29 deletions
diff --git a/gnu/packages/bash.scm b/gnu/packages/bash.scm
index d98ef0582b..02cb45c955 100644
--- a/gnu/packages/bash.scm
+++ b/gnu/packages/bash.scm
@@ -193,8 +193,8 @@ number/base32-hash tuples, directly usable in the 'patch-series' form."
#:tests? #f
#:phases (modify-phases %standard-phases
- (add-after install post-install ,post-install-phase)
- (add-after install install-headers
+ (add-after 'install 'post-install ,post-install-phase)
+ (add-after 'install 'install-headers
,install-headers-phase))))
(synopsis "The GNU Bourne-Again SHell")
(description
diff --git a/gnu/packages/code.scm b/gnu/packages/code.scm
index ed9ba0e31f..9d2bde829d 100644
--- a/gnu/packages/code.scm
+++ b/gnu/packages/code.scm
@@ -142,8 +142,8 @@ a large, deeply nested project.")
(build-system gnu-build-system)
(arguments
'(#:phases (modify-phases %standard-phases
- (delete configure)
- (add-before build make-dotl-files-older
+ (delete 'configure)
+ (add-before 'build 'make-dotl-files-older
(lambda _
;; Make the '.l' files as old as the '.c'
;; files to avoid triggering the rule that
@@ -155,7 +155,7 @@ a large, deeply nested project.")
(set-file-time file ref))
(find-files "." "\\.[chl]$"))
#t))
- (add-before install make-target-directories
+ (add-before 'install 'make-target-directories
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
(mkdir-p (string-append out "/bin"))
@@ -163,7 +163,7 @@ a large, deeply nested project.")
"/share/man/man1"))
(mkdir-p (string-append out
"/share/doc")))))
- (replace check
+ (replace 'check
(lambda _
(setenv "HOME" (getcwd))
(setenv "PATH"
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index dc90a1231d..66f172927f 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -149,7 +149,7 @@ Polygon meshes, and Extruded polygon meshes")
(arguments
'(#:phases
(modify-phases %standard-phases
- (add-after unpack autogen
+ (add-after 'unpack 'autogen
(lambda _
(zero? (system* "sh" "autogen.sh")))))))
(home-page "https://github.com/divVerent/s2tc")
@@ -282,10 +282,10 @@ emulation to complete hardware acceleration for modern GPUs.")
(arguments
'(#:phases
(modify-phases %standard-phases
- (delete configure)
- (delete build)
- (delete check)
- (replace install
+ (delete 'configure)
+ (delete 'build)
+ (delete 'check)
+ (replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(copy-recursively "include" (string-append
(assoc-ref outputs "out")
@@ -318,7 +318,7 @@ emulation to complete hardware acceleration for modern GPUs.")
'(#:phases
(modify-phases %standard-phases
(replace
- install
+ 'install
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
(mkdir-p (string-append out "/bin"))
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 0e674da899..bf19b9ec82 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1639,11 +1639,11 @@ library.")
(arguments
'(#:phases
(modify-phases %standard-phases
- (add-before configure patch-/bin/true
+ (add-before 'configure 'patch-/bin/true
(lambda _
(substitute* "configure"
(("/bin/true") (which "true")))))
- (add-after install wrap-pixbuf
+ (add-after 'install 'wrap-pixbuf
;; Use librsvg's loaders.cache to support SVG files.
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index f574628698..14badc949c 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -181,14 +181,14 @@ output.")
(build-system gnu-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
- (replace configure
+ (replace 'configure
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
(chdir "trunk")
(zero? (system* "qmake"
(string-append
"prefix=" out))))))
- (add-after install wrap-program
+ (add-after 'install 'wrap-program
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(bin (string-append out "/bin"))
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 93dd2ac4e6..ece0e8c54a 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -204,11 +204,11 @@ the W3C's XML-based Scaleable Vector Graphic (SVG) format.")
(modify-phases %standard-phases
;; Prevent make from trying to regenerate config.h.in.
(add-after
- unpack set-config-h-in-file-time
+ 'unpack 'set-config-h-in-file-time
(lambda _
(set-file-time "config/config.h.in" (stat "configure"))))
(add-after
- unpack patch-reg-wrapper
+ 'unpack 'patch-reg-wrapper
(lambda _
(substitute* "prog/reg_wrapper.sh"
((" /bin/sh ")
diff --git a/gnu/packages/key-mon.scm b/gnu/packages/key-mon.scm
index d29f30258d..c890f85f8d 100644
--- a/gnu/packages/key-mon.scm
+++ b/gnu/packages/key-mon.scm
@@ -42,7 +42,7 @@
(arguments
`(#:python ,python-2 ;uses the Python 2 'print' syntax
#:phases (modify-phases %standard-phases
- (add-after install wrap
+ (add-after 'install 'wrap
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(bin (string-append out "/bin"))
diff --git a/gnu/packages/ocr.scm b/gnu/packages/ocr.scm
index 32da42b95f..b94a7f51cb 100644
--- a/gnu/packages/ocr.scm
+++ b/gnu/packages/ocr.scm
@@ -76,7 +76,7 @@ it produces text in 8-bit or UTF-8 formats.")
'(#:phases
(modify-phases %standard-phases
(add-after
- unpack autogen
+ 'unpack 'autogen
(lambda _
(zero? (system* "sh" "autogen.sh")))))
#:configure-flags
diff --git a/gnu/packages/plotutils.scm b/gnu/packages/plotutils.scm
index 245dfe9c67..6166226dce 100644
--- a/gnu/packages/plotutils.scm
+++ b/gnu/packages/plotutils.scm
@@ -118,13 +118,13 @@ using the Cairo drawing library.")
'(#:tests? #f
#:phases
(modify-phases %standard-phases
- (replace configure (lambda _ (chdir "src")))
- (add-before install make-target-directories
+ (replace 'configure (lambda _ (chdir "src")))
+ (add-before 'install 'make-target-directories
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
(mkdir-p (string-append out "/bin"))
#t)))
- (add-after install install-prefabs
+ (add-after 'install 'install-prefabs
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(dir (string-append out
diff --git a/gnu/packages/search.scm b/gnu/packages/search.scm
index d1133248df..4a4ad20759 100644
--- a/gnu/packages/search.scm
+++ b/gnu/packages/search.scm
@@ -76,10 +76,10 @@ rich set of boolean query operators.")
(arguments
`(#:phases (modify-phases %standard-phases
(add-before
- configure chdir-source
+ 'configure 'chdir-source
(lambda _ (chdir "libtocc/src")))
(replace
- check
+ 'check
(lambda _
(with-directory-excursion "../tests"
(and (zero? (system* "./configure"
@@ -113,7 +113,7 @@ files and directories.")
`(#:tests? #f ;No tests
#:phases (modify-phases %standard-phases
(add-after
- unpack chdir-source
+ 'unpack 'chdir-source
(lambda _ (chdir "cli/src"))))))
(home-page "http://t-o-c-c.com/")
(synopsis "Command-line interface to libtocc")
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index bc589a6edb..8223a3fa70 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -738,12 +738,12 @@ several areas.")
'(#:phases
(modify-phases %standard-phases
(add-before
- configure setup-waf
+ 'configure 'setup-waf
(lambda* (#:key inputs #:allow-other-keys)
(copy-file (assoc-ref inputs "waf") "waf")
(setenv "CC" "gcc")))
(add-before
- configure patch-wscript
+ 'configure 'patch-wscript
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "wscript"
;; XXX Remove this when our Samba package provides a .pc file.
@@ -1219,7 +1219,7 @@ capabilities.")
'(#:phases
(modify-phases %standard-phases
(add-after
- unpack autogen
+ 'unpack 'autogen
(lambda _
(zero? (system* "sh" "autogen.sh")))))))
(home-page "http://www.vapoursynth.com/")