summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-10-16 02:26:34 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 12:18:18 -0500
commitf7d88cd4707eeaf02f9b854f05803d8d0428f670 (patch)
tree27ca10374ff37c650a4e27b835b1f73a4cd2035a /gnu/packages
parent698e6f17bb448c36fa7efdb2d24175078716c339 (diff)
downloadguix-patches-f7d88cd4707eeaf02f9b854f05803d8d0428f670.tar
guix-patches-f7d88cd4707eeaf02f9b854f05803d8d0428f670.tar.gz
gnu: libsoup: Update to 3.0.1.
* gnu/packages/gnome.scm (libsoup-minimal): Update to 3.0.1. [modules]: Delete argument. [phases]{adjust-tests}: Re-enable ssl-test. [native-inputs]: Add gnutls, for tests. Move nghttp2:lib to... [propagated-inputs]: ... here. Add nghttp2, which contains the pkg-config files. (vala-0.52): Add older variant. (libsoup-minimal-2): New variable. (rest)[propagated-inputs]: Use libsoup-minimal-2. (geoclue)[inputs]: Likewise. * gnu/packages/inkscape.scm (inkscape)[inputs]: Likewise.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gnome.scm71
-rw-r--r--gnu/packages/inkscape.scm2
2 files changed, 53 insertions, 20 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 059b84f32d..e71e28a46e 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4409,6 +4409,19 @@ the GObject type system and has additional code generation routines that make
targeting the GNOME stack simple.")
(license license:lgpl2.1+)))
+;;; An older variant kept to build libsoup-minimal-2.
+(define-public vala-0.52
+ (package/inherit vala
+ (version "0.52.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/vala/"
+ (version-major+minor version) "/"
+ "vala-" version ".tar.xz"))
+ (sha256
+ (base32
+ "12y6p8wdjp01vmfhxg2cgh32xnyqq6ivblvrar9clnj6vc867qhx"))))))
+
(define-public vte
(package
(name "vte")
@@ -4825,7 +4838,7 @@ from the GSettings schemas in gsettings-desktop-schemas.")
(propagated-inputs
;; rest-0.7.pc refers to all these.
`(("glib" ,glib)
- ("libsoup" ,libsoup-minimal)
+ ("libsoup" ,libsoup-minimal-2)
("libxml2" ,libxml2)))
(home-page "https://www.gtk.org/")
(synopsis "RESTful web api query library")
@@ -4839,7 +4852,7 @@ libxml to ease remote use of the RESTful API.")
(define-public libsoup-minimal
(package
(name "libsoup-minimal")
- (version "2.72.0")
+ (version "3.0.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/libsoup/"
@@ -4847,14 +4860,10 @@ libxml to ease remote use of the RESTful API.")
"libsoup-" version ".tar.xz"))
(sha256
(base32
- "11skbyw2pw32178q3h8pi7xqa41b2x4k6q4k9f75zxmh8s23y30p"))))
+ "0ixwj6d0ryvana6lq1fmbbbin0f2wd5n9iv4ynb8nigq21nk233g"))))
(build-system meson-build-system)
(arguments
- `(#:modules ((guix build utils)
- (guix build meson-build-system)
- (ice-9 popen))
-
- #:configure-flags '("-Dgtk_doc=false")
+ `(#:configure-flags '("-Dgtk_doc=false")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'adjust-tests
@@ -4872,14 +4881,9 @@ libxml to ease remote use of the RESTful API.")
((".*/hsts/superdomain.*") "")
((".*/hsts/utf8-address.*") ""))
(substitute* "tests/hsts-db-test.c"
- ((".*/hsts-db/subdomains.*") ""))
-
- ;; FIXME: ssl-test fails, starting with
- ;; glib-networking 2.68.x.
- (substitute* "tests/meson.build"
- (("[ \t]*\\['ssl', true, \\[\\]\\],") "")))))))
+ ((".*/hsts-db/subdomains.*") "")))))))
(native-inputs
- `(("glib:bin" ,glib "bin") ; for glib-mkenums
+ `(("glib:bin" ,glib "bin") ;for glib-mkenums
("gobject-introspection" ,gobject-introspection)
("intltool" ,intltool)
("pkg-config" ,pkg-config)
@@ -4887,19 +4891,22 @@ libxml to ease remote use of the RESTful API.")
("vala" ,vala)
("php" ,php)
("curl" ,curl)
+ ("gnutls" ,gnutls) ;for 'certtool'
("httpd" ,httpd)))
(propagated-inputs
- ;; libsoup-2.4.pc refers to all of these (except where otherwise noted)
+ ;; libsoup-3.0.pc refers to all of these (except where otherwise noted)
`(("brotli" ,brotli)
("glib" ,glib)
- ("glib-networking" ,glib-networking) ; for GIO runtime modules
+ ("glib-networking" ,glib-networking) ; for GIO runtime modules
("libpsl" ,libpsl)
+ ("nghttp2" ,nghttp2) ;for pkg-config
+ ("nghttp2:lib" ,nghttp2 "lib")
("libxml2" ,libxml2)
("sqlite" ,sqlite)
("zlib" ,zlib)))
(inputs
`(("mit-krb5" ,mit-krb5)
- ("ntlm_auth" ,samba))) ; For ntlm_auth support
+ ("ntlm_auth" ,samba))) ; For ntlm_auth support
(home-page "https://wiki.gnome.org/Projects/libsoup")
(synopsis "GLib-based HTTP Library")
(description
@@ -4907,6 +4914,32 @@ libxml to ease remote use of the RESTful API.")
and the GLib main loop, to integrate well with GNOME applications.")
(license license:lgpl2.0+)))
+;;; An older variant kept to build the 'rest' package.
+(define-public libsoup-minimal-2
+ (package/inherit libsoup-minimal
+ (version "2.72.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/libsoup/"
+ (version-major+minor version) "/"
+ "libsoup-" version ".tar.xz"))
+ (sha256
+ (base32
+ "11skbyw2pw32178q3h8pi7xqa41b2x4k6q4k9f75zxmh8s23y30p"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments libsoup-minimal)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-after 'unpack 'disable-failing-tests
+ (lambda _
+ ;; Disable the SSL test, failing since 2.68 and resolved in
+ ;; libsoup 3.
+ (substitute* "tests/meson.build"
+ (("[ \t]*\\['ssl', true, \\[\\]\\],") ""))))))))
+ (native-inputs
+ (cons `("vala" ,vala-0.52)
+ (delete "vala" (package-native-inputs libsoup-minimal))))))
+
(define-public libsoup
(package/inherit libsoup-minimal
(name "libsoup")
@@ -5340,7 +5373,7 @@ output devices.")
("glib:bin" ,glib "bin")
("glib-networking" ,glib-networking)
("json-glib" ,json-glib)
- ("libsoup" ,libsoup)))
+ ("libsoup" ,libsoup-minimal-2)))
(home-page "https://gitlab.freedesktop.org/geoclue/geoclue/-/wikis/home")
(synopsis "Geolocation service")
(description "Geoclue is a D-Bus service that provides location
diff --git a/gnu/packages/inkscape.scm b/gnu/packages/inkscape.scm
index 2328410760..ed40322e0d 100644
--- a/gnu/packages/inkscape.scm
+++ b/gnu/packages/inkscape.scm
@@ -206,7 +206,7 @@ endif()~%~%"
("libxml2" ,libxml2)
("libxslt" ,libxslt)
("libgc" ,libgc)
- ("libsoup" ,libsoup-minimal)
+ ("libsoup" ,libsoup-minimal-2)
("libcdr" ,libcdr)
("libvisio" ,libvisio)
("libwpd" ,libwpd)