summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2021-03-25 10:35:55 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2021-03-25 10:35:55 +0100
commitf445407df67b7c1ead0cae1456a619c24db1a874 (patch)
treed2336e965aa7fea5c3e824a5abeac87f5769fb46 /gnu/packages
parent27d967dfa44aaffd610bed29d88a7161ef144119 (diff)
downloadguix-patches-f445407df67b7c1ead0cae1456a619c24db1a874.tar
guix-patches-f445407df67b7c1ead0cae1456a619c24db1a874.tar.gz
gnu: Add html-template.
* gnu/packages/lisp-xyz.scm (cl-html-template, ecl-html-template, sbcl-html-template): New variables.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/lisp-xyz.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 5682daee3f..c40995491f 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -15342,3 +15342,40 @@ numbers in Common Lisp.")
(define-public cl-computable-reals
(sbcl-package->cl-source-package sbcl-computable-reals))
+
+(define-public sbcl-html-template
+ (package
+ (name "sbcl-html-template")
+ (version "0.9.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/edicl/html-template")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0wz3czvjsn4x971dsiia9f9nvvcmbkablcl75zsvxndkimc93wxb"))))
+ (build-system asdf-build-system/sbcl)
+ (home-page "https://edicl.github.io/html-template/")
+ (synopsis "HTML templates from Common Lisp")
+ (description
+ "HTML-TEMPLATE is a Common Lisp library which can be used to fill
+templates with arbitrary (string) values at runtime. The result does not have
+to be HTML.
+
+It is loosely modeled after the Perl module @code{HTML::Template} and
+partially compatible with a its syntax, though both libraries contain some
+extensions that the other does not support.
+
+HTML-TEMPLATE translates templates into efficient closures which can be
+re-used as often as needed. It uses a cache mechanism so you can update
+templates while your program is running and have the changes take effect
+immediately.")
+ (license license:bsd-2)))
+
+(define-public ecl-html-template
+ (sbcl-package->ecl-package sbcl-html-template))
+
+(define-public cl-html-template
+ (sbcl-package->cl-source-package sbcl-html-template))