summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-16 16:44:14 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-16 16:44:14 +0300
commitef9a5521823c7d8c6fe954189d6feb312a3be6fa (patch)
tree62ee67bf8c06b9eef8b6c5c536338b6a3bc106b4 /gnu/packages
parent9e77eb588443a0147bfaaa0559b1eb5c53ee5af3 (diff)
downloadguix-patches-ef9a5521823c7d8c6fe954189d6feb312a3be6fa.tar
guix-patches-ef9a5521823c7d8c6fe954189d6feb312a3be6fa.tar.gz
gnu: Add julia-suppressor.
* gnu/packages/julia-xyz.scm (julia-suppressor): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/julia-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 0ca4326990..f8d51f2dd0 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -1276,6 +1276,26 @@ statically sized arrays in Julia, using the abstract type
linear algebra operations.")
(license license:expat)))
+(define-public julia-suppressor
+ (package
+ (name "julia-suppressor")
+ (version "0.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaIO/Suppressor.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0v6pxvf8lzrqjc676snvlszh14ridl442g2h6syfjiy75pk7mdyc"))))
+ (build-system julia-build-system)
+ (home-page "https://github.com/JuliaIO/Suppressor.jl")
+ (synopsis "Capture stdout and sterr")
+ (description "Julia macros for suppressing and/or capturing output (stdout),
+warnings (stderr) or both streams at the same time.")
+ (license license:expat)))
+
(define-public julia-uris
(package
(name "julia-uris")