summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-06-22 19:26:42 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-06-22 22:00:24 +0200
commiteeb8b0e631f6487a3bf138f23aa4792c4e3d3a2e (patch)
tree8b9b90c484ec9823fc1ef2669dfa0e443a67fd0b /gnu/packages
parent0d0252e45768b2a638a6b018735aab30d27d22ee (diff)
downloadguix-patches-eeb8b0e631f6487a3bf138f23aa4792c4e3d3a2e.tar
guix-patches-eeb8b0e631f6487a3bf138f23aa4792c4e3d3a2e.tar.gz
gnu: Use more HTTPS.
* gnu/packages/admin.scm (net-base, wakelan, pam-krb5) [home-page]: Use HTTPS. (dfc, libpcap, tcpdump, wpa-supplicant-minimal, libcap-ng, audit) [source, home-page]: Likewise. * gnu/packages/algebra.scm (eigen)[home-page]: Likewise. (gp2c, pari-gp)[source, home-page]: Likewise. * gnu/packages/animation.scm (etl, synfig, synfigstudio, papagayo) [home-page]: Likewise. * gnu/packages/bioinformatics.scm (tadbit)[home-page]: Likewise.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/admin.scm28
-rw-r--r--gnu/packages/algebra.scm10
-rw-r--r--gnu/packages/animation.scm8
-rw-r--r--gnu/packages/bioinformatics.scm2
4 files changed, 24 insertions, 24 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 431fc28351..6b8af60b1b 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -256,7 +256,7 @@ services.")
(origin
(method url-fetch)
(uri (string-append
- "http://projects.gw-computing.net/attachments/download/615/dfc-"
+ "https://projects.gw-computing.net/attachments/download/615/dfc-"
version ".tar.gz"))
(sha256
(base32
@@ -264,7 +264,7 @@ services.")
(build-system cmake-build-system)
(arguments '(#:tests? #f)) ; There are no tests.
(native-inputs `(("gettext" ,gettext-minimal)))
- (home-page "http://projects.gw-computing.net/projects/dfc")
+ (home-page "https://projects.gw-computing.net/projects/dfc")
(synopsis "Display file system space usage using graphs and colors")
(description
"dfc (df color) is a modern version of df. It uses colors, draws pretty
@@ -508,7 +508,7 @@ allow automatic login and starting any app.")
"This package provides the /etc/services, /etc/protocols, and /etc/rpc
files, which contain information about the IANA-assigned port, protocol, and
ONC RPC numbers.")
- (home-page "http://packages.debian.org/sid/netbase")
+ (home-page "https://packages.debian.org/sid/netbase")
(license license:gpl2)))
(define-public netcat
@@ -753,7 +753,7 @@ tools: server, client, and relay agent.")
(version "1.8.1")
(source (origin
(method url-fetch)
- (uri (string-append "http://www.tcpdump.org/release/libpcap-"
+ (uri (string-append "https://www.tcpdump.org/release/libpcap-"
version ".tar.gz"))
(sha256
(base32
@@ -762,7 +762,7 @@ tools: server, client, and relay agent.")
(native-inputs `(("bison" ,bison) ("flex" ,flex)))
(arguments '(#:configure-flags '("--with-pcap=linux")
#:tests? #f)) ; no 'check' target
- (home-page "http://www.tcpdump.org")
+ (home-page "https://www.tcpdump.org")
(synopsis "Network packet capture library")
(description
"libpcap is an interface for user-level packet capture. It provides a
@@ -778,7 +778,7 @@ network statistics collection, security monitoring, network debugging, etc.")
(version "4.9.2")
(source (origin
(method url-fetch)
- (uri (string-append "http://www.tcpdump.org/release/tcpdump-"
+ (uri (string-append "https://www.tcpdump.org/release/tcpdump-"
version ".tar.gz"))
(sha256
(base32
@@ -787,7 +787,7 @@ network statistics collection, security monitoring, network debugging, etc.")
(inputs `(("libpcap" ,libpcap)
("openssl" ,openssl)))
(native-inputs `(("perl" ,perl))) ; for tests
- (home-page "http://www.tcpdump.org/")
+ (home-page "https://www.tcpdump.org/")
(synopsis "Network packet analyzer")
(description
"Tcpdump is a command-line tool to analyze network traffic passing
@@ -1043,7 +1043,7 @@ commands and their arguments.")
(source (origin
(method url-fetch)
(uri (string-append
- "http://w1.fi/releases/wpa_supplicant-"
+ "https://w1.fi/releases/wpa_supplicant-"
version
".tar.gz"))
(patches (search-patches "wpa-supplicant-CVE-2017-13082.patch"
@@ -1104,7 +1104,7 @@ commands and their arguments.")
("libgcrypt" ,libgcrypt))) ;needed by crypto_gnutls.c
(native-inputs
`(("pkg-config" ,pkg-config)))
- (home-page "http://w1.fi/wpa_supplicant/")
+ (home-page "https://w1.fi/wpa_supplicant/")
(synopsis "Connecting to WPA and WPA2-protected wireless networks")
(description
"wpa_supplicant is a WPA Supplicant with support for WPA and WPA2 (IEEE
@@ -1221,7 +1221,7 @@ This package provides the 'wpa_supplicant' daemon and the 'wpa_cli' command.")
(string-append "--mandir=" out
"/share/man")))))))
#:tests? #f))
- (home-page "http://kernel.org") ; really, no home page
+ (home-page "https://www.kernel.org") ; really, no home page
(synopsis "Send a wake-on-LAN packet")
(description
"WakeLan broadcasts a properly formatted UDP packet across the local area
@@ -1456,7 +1456,7 @@ track changes in important system configuration files.")
(source (origin
(method url-fetch)
(uri (string-append
- "http://people.redhat.com/sgrubb/libcap-ng/libcap-ng-"
+ "https://people.redhat.com/sgrubb/libcap-ng/libcap-ng-"
version ".tar.gz"))
(sha256
(base32
@@ -1792,13 +1792,13 @@ platform-specific methods.")
(version "2.4.5")
(source (origin
(method url-fetch)
- (uri (string-append "http://people.redhat.com/sgrubb/audit/"
+ (uri (string-append "https://people.redhat.com/sgrubb/audit/"
"audit-" version ".tar.gz"))
(sha256
(base32
"1q1q51dvxscbi4kbakmd4bn0xrvwwaiwvaya79925cbrqwzxsg77"))))
(build-system gnu-build-system)
- (home-page "http://people.redhat.com/sgrubb/audit/")
+ (home-page "https://people.redhat.com/sgrubb/audit/")
(arguments
`(#:configure-flags (list "--with-python=no")
#:phases
@@ -2127,7 +2127,7 @@ with @code{ChallengeResponseAuthentication} and @code{PrivilegeSeparation}
enabled, and supports extensive configuration either by PAM options or in
krb5.conf or both. PKINIT is supported with recent versions of both MIT
Kerberos and Heimdal and FAST is supported with recent MIT Kerberos.")
- (home-page "http://www.eyrie.org/~eagle/software/pam-krb5")
+ (home-page "https://www.eyrie.org/~eagle/software/pam-krb5")
;; Dual licenced under a homebrew non-copyleft OR GPL (any version)
;; However, the tarball does not contain a copy of the GPL, so unless
;; we put one in, we cannot distribute it under GPL without violating
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 816f013655..45d15d6fd5 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -143,7 +143,7 @@ solve the shortest vector problem.")
(source (origin
(method url-fetch)
(uri (string-append
- "http://pari.math.u-bordeaux.fr/pub/pari/unix/pari-"
+ "https://pari.math.u-bordeaux.fr/pub/pari/unix/pari-"
version ".tar.gz"))
(sha256
(base32
@@ -174,7 +174,7 @@ polynomials, power series, algebraic numbers, etc., and a lot of
transcendental functions.
PARI is also available as a C library to allow for faster computations.")
(license license:gpl2+)
- (home-page "http://pari.math.u-bordeaux.fr/")))
+ (home-page "https://pari.math.u-bordeaux.fr/")))
(define-public gp2c
(package
@@ -183,7 +183,7 @@ PARI is also available as a C library to allow for faster computations.")
(source (origin
(method url-fetch)
(uri (string-append
- "http://pari.math.u-bordeaux.fr/pub/pari/GP2C/gp2c-"
+ "https://pari.math.u-bordeaux.fr/pub/pari/GP2C/gp2c-"
version ".tar.gz"))
(sha256
(base32
@@ -208,7 +208,7 @@ PARI is also available as a C library to allow for faster computations.
GP2C, the GP to C compiler, translates GP scripts to PARI programs.")
(license license:gpl2)
- (home-page "http://pari.math.u-bordeaux.fr/")))
+ (home-page "https://pari.math.u-bordeaux.fr/")))
(define-public giac-xcas
(package
@@ -746,7 +746,7 @@ Sine Transform} (DST) and @dfn{Discrete Hartley Transform} (DHT).")
;; Then run 'CTest' with -V so we get more
;; details upon failure.
(zero? (system* "ctest" "-V" dash-j)))))))))
- (home-page "http://eigen.tuxfamily.org")
+ (home-page "https://eigen.tuxfamily.org")
(synopsis "C++ template library for linear algebra")
(description
"Eigen is a C++ template library for linear algebra: matrices, vectors,
diff --git a/gnu/packages/animation.scm b/gnu/packages/animation.scm
index b56a081984..22af707401 100644
--- a/gnu/packages/animation.scm
+++ b/gnu/packages/animation.scm
@@ -52,7 +52,7 @@
(base32
"0ii73nsd3xzkhz6w1rnxwphl637j9w82xiy6apa9vin2isdynnmc"))))
(build-system gnu-build-system)
- (home-page "http://www.synfig.org")
+ (home-page "https://www.synfig.org")
(synopsis "Extended C++ template library")
(description
"ETL is a class and template library designed to add new datatypes and
@@ -130,7 +130,7 @@ C++ @dfn{Standard Template Library} (STL).")
("pango" ,pango)))
(native-inputs
`(("pkg-config" ,pkg-config)))
- (home-page "http://www.synfig.org")
+ (home-page "https://www.synfig.org")
(synopsis "Vector-based 2D animation renderer")
(description
"Synfig is a vector-based 2D animation package. It is designed to be
@@ -180,7 +180,7 @@ for tweening, preventing the need to hand-draw each frame.")
(native-inputs
`(("pkg-config" ,pkg-config)
("intltool" ,intltool)))
- (home-page "http://www.synfig.org")
+ (home-page "https://www.synfig.org")
(synopsis "Vector-based 2D animation package (GUI)")
(description
"Synfig is a vector-based 2D animation package. It is designed to
@@ -248,7 +248,7 @@ contains the graphical user interface for synfig.")
("libsndfile" ,libsndfile)))
(native-inputs
`(("qttools" ,qttools)))
- (home-page "http://www.lostmarble.com/papagayo/")
+ (home-page "https://www.lostmarble.com/papagayo/")
(synopsis "Lip-syncing for animations")
(description
"Papagayo is a lip-syncing program designed to help you line up
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index ecc1c06630..f89c60b8cd 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -11449,7 +11449,7 @@ applications for tackling some common problems in a user-friendly way.")
("python2-numpy" ,python2-numpy)
("python2-matplotlib" ,python2-matplotlib)
("python2-pysam" ,python2-pysam)))
- (home-page "http://3dgenomes.github.io/TADbit/")
+ (home-page "https://3dgenomes.github.io/TADbit/")
(synopsis "Analyze, model, and explore 3C-based data")
(description
"TADbit is a complete Python library to deal with all steps to analyze,