summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorFederico Beffa <beffa@fbengineering.ch>2014-11-26 17:29:16 +0100
committerFederico Beffa <beffa@fbengineering.ch>2014-11-27 09:50:47 +0100
commitec00de358ed0df0a82b8520407f5e1440973ac93 (patch)
tree9853001c3648ed2bf934e54249e3f184eabcf39e /gnu/packages
parent598e19dca1677aebfe235e974f480b5bdd322694 (diff)
downloadguix-patches-ec00de358ed0df0a82b8520407f5e1440973ac93.tar
guix-patches-ec00de358ed0df0a82b8520407f5e1440973ac93.tar.gz
gnu: Add numpydoc.
* gnu/packages/python.scm (python-numpydoc, python2-numpydoc): New variables.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index c0eea3c631..68dc67f1f2 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1981,3 +1981,37 @@ that client code uses to construct the grammar directly in Python code.")
(define-public python2-pyparsing
(package-with-python2 python-pyparsing))
+(define-public python-numpydoc
+ (package
+ (name "python-numpydoc")
+ (version "0.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/n/numpydoc/numpydoc-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0d4dnifaxkll50jx6czj05y8cb4ny60njd2wz299sj2jxfy51w4k"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-setuptools" ,python-setuptools)
+ ("python-docutils" ,python-docutils)
+ ("python-sphinx" ,python-sphinx)
+ ("python-nose" ,python-nose)))
+ (home-page "https://pypi.python.org/pypi/numpydoc")
+ (synopsis
+ "Numpy's Sphinx extensions")
+ (description
+ "Sphinx extension to support docstrings in Numpy format.")
+ (license bsd-2)))
+
+(define-public python2-numpydoc
+ (package
+ (inherit (package-with-python2 python-numpydoc))
+ ;; With python-2 1 test (out of 30) fails because it doesn't find
+ ;; matplotlib. With python-3 it seems to detect at run-time the absence
+ ;; of matplotlib.
+ (arguments `(#:tests? #f
+ #:python ,python-2))))