summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-01-31 14:30:31 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-01-31 14:36:08 +0200
commite5a2edeba04406b652179e4675d845f4432baa02 (patch)
tree2076bff1c717ceaed499d0e02cbaea6850007c7b /gnu/packages
parent39eefcee9773cd4a337cec639cfbdbeca27b3ad9 (diff)
downloadguix-patches-e5a2edeba04406b652179e4675d845f4432baa02.tar
guix-patches-e5a2edeba04406b652179e4675d845f4432baa02.tar.gz
gnu: perl-tk: Update to 804.033.
* gnu/packages/tcl.scm (perl-tk): Update to 804.033. [source]: Remove patch. * gnu/packages/patches/perl-tk-x11-discover.patch: Remove file. * gnu-system.am (dist_patch_DATA): Remove patch.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/patches/perl-tk-x11-discover.patch14
-rw-r--r--gnu/packages/tcl.scm6
2 files changed, 3 insertions, 17 deletions
diff --git a/gnu/packages/patches/perl-tk-x11-discover.patch b/gnu/packages/patches/perl-tk-x11-discover.patch
deleted file mode 100644
index f4365e6882..0000000000
--- a/gnu/packages/patches/perl-tk-x11-discover.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-On non-x86_64 systems, this conditional can cause a specified X11 build value
-to be overwritten to null, causing x11 discovery to fail.
-
---- a/myConfig 2014-05-12 11:16:48.152719722 -0500
-+++ b/myConfig 2014-05-12 11:16:24.704719113 -0500
-@@ -350,7 +350,7 @@
- #
- # Prefer 64bit libraries on certain architectures
- #
-- unless (defined $xlib and $Config{'archname'} =~ m/x86_64/)
-+ unless (defined $xlib or not $Config{'archname'} =~ m/x86_64/)
- {
- $xlib64 = &lX11(0, chooseX11(</usr/X11*/lib64>));
- }
diff --git a/gnu/packages/tcl.scm b/gnu/packages/tcl.scm
index 6f6838c039..2c4c750997 100644
--- a/gnu/packages/tcl.scm
+++ b/gnu/packages/tcl.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -187,7 +188,7 @@ interfaces (GUIs) in the Tcl language.")
(define-public perl-tk
(package
(name "perl-tk")
- (version "804.032")
+ (version "804.033")
(source (origin
(method url-fetch)
(uri (string-append
@@ -195,8 +196,7 @@ interfaces (GUIs) in the Tcl language.")
version ".tar.gz"))
(sha256
(base32
- "0jarvplhfvnm0shhdm2a5zczlnk9mkf8jvfjiwyhjrr3cy1gl0w0"))
- (patches (list (search-patch "perl-tk-x11-discover.patch")))))
+ "1bc8bacsf95598yimrxijymb3advrgan73pqxj75qmd20ydnwxc4"))))
(build-system perl-build-system)
(native-inputs `(("pkg-config" ,pkg-config)))
(inputs `(("libx11" ,libx11)