summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorAnders Thuné <asse.97@gmail.com>2020-07-14 10:18:54 +0200
committerLudovic Courtès <ludo@gnu.org>2020-07-27 12:06:36 +0200
commite4b8feaf5c503ae5e13efa565a2b6c7b4bb2f946 (patch)
tree1023fcb672a3272a6e14ce847b8c89c20bd8ec11 /gnu/packages
parent911504377fa6be2b523c58d8208d17193bd53a34 (diff)
downloadguix-patches-e4b8feaf5c503ae5e13efa565a2b6c7b4bb2f946.tar
guix-patches-e4b8feaf5c503ae5e13efa565a2b6c7b4bb2f946.tar.gz
gnu: Add xdg-desktop-portal-gtk.
* gnu/packages/freedesktop.scm (xdg-desktop-portal-gtk): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/freedesktop.scm53
1 files changed, 53 insertions, 0 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 885fbd6269..ddbe716dd1 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -48,6 +48,7 @@
#:use-module (guix build-system meson)
#:use-module (guix build-system perl)
#:use-module (guix build-system python)
+ #:use-module (guix build-system glib-or-gtk)
#:use-module (gnu packages)
#:use-module (gnu packages acl)
#:use-module (gnu packages admin)
@@ -1973,3 +1974,55 @@ path (@code{/org/freedesktop/portal/desktop}).
The portal interfaces include APIs for file access, opening URIs, printing
and others.")
(license license:lgpl2.1+)))
+
+(define-public xdg-desktop-portal-gtk
+ (package
+ (name "xdg-desktop-portal-gtk")
+ (version "1.7.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/flatpak/xdg-desktop-portal-gtk")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "183iha9dxmvprn99ymgz17jx1lyn1fj5jyj6ghxl716zn9mxmird"))))
+ (build-system glib-or-gtk-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'po-chmod
+ (lambda _
+ ;; Make sure 'msgmerge' can modify the PO files.
+ (for-each (lambda (po)
+ (chmod po #o666))
+ (find-files "po" "\\.po$"))
+ #t)))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("xdg-desktop-portal" ,xdg-desktop-portal)
+ ("glib:bin" ,glib "bin")
+ ("which" ,which)
+ ("gettext" ,gettext-minimal)))
+ (inputs
+ `(("glib" ,glib)
+ ("gtk" ,gtk+)
+ ("fontconfig" ,fontconfig)
+ ("gnome-desktop" ,gnome-desktop)
+ ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)))
+ (native-search-paths
+ (list (search-path-specification
+ (variable "XDG_DESKTOP_PORTAL_DIR")
+ (files '("share/xdg-desktop-portal/portals")))))
+ (home-page "https://github.com/flatpak/xdg-desktop-portal-gtk")
+ (synopsis "GTK implementation of xdg-desktop-portal")
+ (description
+ "This package provides a backend implementation for xdg-desktop-portal
+which uses GTK+ and various pieces of GNOME infrastructure, such as the
+@code{org.gnome.Shell.Screenshot} or @code{org.gnome.SessionManager} D-Bus
+interfaces.")
+ (license license:lgpl2.1+)))