summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-09-28 11:40:26 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-15 22:31:30 +0100
commite0ed457944d1166d8d2bb53dab6e724989d1576c (patch)
tree48e26095d049b6af0dd6edceae8cf82f475ee3d2 /gnu/packages
parentc4516ad206ab8558b3de5695fd62851855a31439 (diff)
downloadguix-patches-e0ed457944d1166d8d2bb53dab6e724989d1576c.tar
guix-patches-e0ed457944d1166d8d2bb53dab6e724989d1576c.tar.gz
gnu: python-setuptools: remove pre-built binaries from source.
These are used to build self-extracting installers for Windows. * gnu/packages/python.scm (python-setuptools, python2-setuptools) [source]: Add snippet to delete *.exe files.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index e091ceff65..1ecfb6ccbc 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -825,7 +825,15 @@ have been used.")
version ".tar.gz"))
(sha256
(base32
- "0kc7rbav00ks6iaw14p38y81q12fx0lpkhgf5m97xc04f5r318ig"))))
+ "0kc7rbav00ks6iaw14p38y81q12fx0lpkhgf5m97xc04f5r318ig"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Remove included binaries which are used to build self-extracting
+ ;; installers for Windows.
+ ;; TODO: Find some way to build them ourself so we can include them.
+ (for-each delete-file (find-files "setuptools" "^(cli|gui).*\\.exe$"))
+ #t))))
(build-system python-build-system)
;; FIXME: Tests require pytest, which itself relies on setuptools.
;; One could bootstrap with an internal untested setuptools.