summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-11-06 23:32:54 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-11-06 23:32:54 +0200
commitdd87bbb2b78b279248aaff15c0706fcd6d8cd7bb (patch)
tree39c6330f6150239776de1f2eb3fd4161a5c4e074 /gnu/packages
parent71ad48f7bbbb581e53c110224c591b81e3c47b0c (diff)
downloadguix-patches-dd87bbb2b78b279248aaff15c0706fcd6d8cd7bb.tar
guix-patches-dd87bbb2b78b279248aaff15c0706fcd6d8cd7bb.tar.gz
gnu: python-poppler-qt5: Fix building.
* gnu/packages/pdf.scm (python-poppler-qt5)[source]: Add patch. * gnu/packages/patches/python-poppler-qt5-fix-build.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/patches/python-poppler-qt5-fix-build.patch116
-rw-r--r--gnu/packages/pdf.scm3
2 files changed, 118 insertions, 1 deletions
diff --git a/gnu/packages/patches/python-poppler-qt5-fix-build.patch b/gnu/packages/patches/python-poppler-qt5-fix-build.patch
new file mode 100644
index 0000000000..099bb86d2f
--- /dev/null
+++ b/gnu/packages/patches/python-poppler-qt5-fix-build.patch
@@ -0,0 +1,116 @@
+Patch taken from the upstream repository
+https://github.com/frescobaldi/python-poppler-qt5/issues/43
+
+From 92e5962ec3751ab051d0b655fd61afc7a1cf709e Mon Sep 17 00:00:00 2001
+From: Ben Greiner <code@bnavigator.de>
+Date: Thu, 4 Mar 2021 17:02:51 +0100
+Subject: [PATCH] map type QVector< QPair<TYPE, TYPE> > for
+ FormFieldChoice::choicesWithExportValues() (#45)
+
+---
+ types.sip | 93 +++++++++++++++++++++++++++++++++++++++++++++++++++++++
+ 1 file changed, 93 insertions(+)
+
+diff --git a/types.sip b/types.sip
+index 239b8c9..81cb283 100644
+--- a/types.sip
++++ b/types.sip
+@@ -331,5 +331,98 @@ template <TYPE>
+ };
+
+
++/**
++ * Convert QVector< QPair<TYPE, TYPE> >
++ * from and to a Python list of a 2-item tuple
++ */
++
++template<TYPE>
++%MappedType QVector< QPair<TYPE, TYPE> >
++{
++%TypeHeaderCode
++#include <qvector.h>
++#include <qpair.h>
++%End
++
++%ConvertFromTypeCode
++ // Create the list.
++ PyObject *l;
++
++ if ((l = PyList_New(sipCpp->size())) == NULL)
++ return NULL;
++
++ // Set the list elements.
++ for (int i = 0; i < sipCpp->size(); ++i)
++ {
++ QPair<TYPE, TYPE>* p = new QPair<TYPE, TYPE>(sipCpp->at(i));
++ PyObject *ptuple = PyTuple_New(2);
++ PyObject *pfirst;
++ PyObject *psecond;
++
++ TYPE *sfirst = new TYPE(p->first);
++ if ((pfirst = sipConvertFromType(sfirst, sipType_TYPE, sipTransferObj)) == NULL)
++ {
++ Py_DECREF(l);
++ Py_DECREF(ptuple);
++ return NULL;
++ }
++ PyTuple_SET_ITEM(ptuple, 0, pfirst);
++
++ TYPE *ssecond = new TYPE(p->second);
++ if ((psecond = sipConvertFromType(ssecond, sipType_TYPE, sipTransferObj)) == NULL)
++ {
++ Py_DECREF(l);
++ Py_DECREF(ptuple);
++ Py_DECREF(pfirst);
++ return NULL;
++ }
++ PyTuple_SET_ITEM(ptuple, 1, psecond);
++
++ PyList_SET_ITEM(l, i, ptuple);
++ }
++
++ return l;
++%End
++
++%ConvertToTypeCode
++ const sipTypeDef* qpair_type = sipFindType("QPair<TYPE, TYPE>");
++
++ // Check the type if that is all that is required.
++ if (sipIsErr == NULL)
++ {
++ if (!PySequence_Check(sipPy))
++ return 0;
++
++ for (int i = 0; i < PySequence_Size(sipPy); ++i)
++ if (!sipCanConvertToType(PySequence_ITEM(sipPy, i), qpair_type, SIP_NOT_NONE))
++ return 0;
++
++ return 1;
++ }
++
++
++ QVector< QPair<TYPE, TYPE> > *qv = new QVector< QPair<TYPE, TYPE> >;
++
++ for (int i = 0; i < PySequence_Size(sipPy); ++i)
++ {
++ int state;
++ QPair<TYPE, TYPE> * p = reinterpret_cast< QPair<TYPE, TYPE> * >(sipConvertToType(PySequence_ITEM(sipPy, i), qpair_type, sipTransferObj, SIP_NOT_NONE, &state, sipIsErr));
++
++ if (*sipIsErr)
++ {
++ sipReleaseType(p, qpair_type, state);
++ delete qv;
++ return 0;
++ }
++ qv->append(*p);
++ sipReleaseType(p, qpair_type, state);
++ }
++
++ *sipCppPtr = qv;
++ return sipGetState(sipTransferObj);
++%End
++
++};
++
+
+ /* kate: indent-width 4; space-indent on; hl c++; indent-mode cstyle; */
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 9a638802a2..a251c8ef78 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -328,7 +328,8 @@ When present, Poppler is able to correctly render CJK and Cyrillic text.")
(uri (pypi-uri "python-poppler-qt5" version))
(sha256
(base32
- "0b82gm4i75q5v19kfbq0h4y0b2vcwr2213zkhxh6l0h45kdndmxd"))))
+ "0b82gm4i75q5v19kfbq0h4y0b2vcwr2213zkhxh6l0h45kdndmxd"))
+ (patches (search-patches "python-poppler-qt5-fix-build.patch"))))
(build-system python-build-system)
(arguments
`(;; There are no tests. The check phase just causes a rebuild.