summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-05-02 13:48:11 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-05-04 16:53:48 +0200
commitc9c63edbde6aaf774d263036d4f14da25c88ed53 (patch)
tree261c98e3f8c7e3e9a9a5d6da728a298e4da36798 /gnu/packages
parent46c39e1e47f158c338ac9c4bd4c62e72fe9bf2d2 (diff)
downloadguix-patches-c9c63edbde6aaf774d263036d4f14da25c88ed53.tar
guix-patches-c9c63edbde6aaf774d263036d4f14da25c88ed53.tar.gz
gnu: gstreamer: Update to 1.16.0.
* gnu/packages/gstreamer.scm (gstreamer, gst-plugins-base, gst-plugins-bad, gst-plugins-ugly, python-gst): Update to 1.16.0. (gst-plugins-good): Likewise. [source](patches): Remove. [arguments]: Remove #:make-flags. (gst-libav): Update to 1.16.0. [inputs]: Change FFMPEG-3.4 to FFMPEG. * gnu/packages/patches/gst-plugins-good-libvpx-compat.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gstreamer.scm34
-rw-r--r--gnu/packages/patches/gst-plugins-good-libvpx-compat.patch58
2 files changed, 16 insertions, 76 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 7c9b68bb2e..d5d14152fb 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -102,7 +102,7 @@ arrays of data.")
(define-public gstreamer
(package
(name "gstreamer")
- (version "1.14.4")
+ (version "1.16.0")
(source
(origin
(method url-fetch)
@@ -111,7 +111,7 @@ arrays of data.")
version ".tar.xz"))
(sha256
(base32
- "1izzhnlsy83rgr4zl3jcl1sryxqbbigrrqw3j4x3nnphqnb6ckzr"))))
+ "003wy1p1in85p9sr5jsyhbnwqaiwz069flwkhyx7qhxy31qjz3hf"))))
(build-system gnu-build-system)
(outputs '("out" "doc"))
(arguments
@@ -150,7 +150,7 @@ This package provides the core library and elements.")
(define-public gst-plugins-base
(package
(name "gst-plugins-base")
- (version "1.14.4")
+ (version "1.16.0")
(source
(origin
(method url-fetch)
@@ -158,7 +158,7 @@ This package provides the core library and elements.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0qbllw4kphchwhy4p7ivdysigx69i97gyw6q0rvkx1j81r4kjqfa"))))
+ "1bmmdwbyy89ayb85xc48y217f6wdmpz96f30zm6v53z2a5xsm4s0"))))
(build-system gnu-build-system)
(outputs '("out" "doc"))
(propagated-inputs
@@ -209,17 +209,16 @@ for the GStreamer multimedia library.")
(define-public gst-plugins-good
(package
(name "gst-plugins-good")
- (version "1.14.4")
+ (version "1.16.0")
(source
(origin
(method url-fetch)
(uri (string-append
"https://gstreamer.freedesktop.org/src/" name "/"
name "-" version ".tar.xz"))
- (patches (search-patches "gst-plugins-good-libvpx-compat.patch"))
(sha256
(base32
- "0y89qynb4b6fry3h43z1r99qslmi3m8xhlq0i5baq2nbc0r5b2sz"))))
+ "1zdhif1mhf0ihkjpjyrh65g2iz2cawkjjb3h5w8h9ml06grxwjk5"))))
(build-system gnu-build-system)
(inputs
`(("aalib" ,aalib)
@@ -251,8 +250,7 @@ for the GStreamer multimedia library.")
("pkg-config" ,pkg-config)
("python-wrapper" ,python-wrapper)))
(arguments
- `(#:make-flags '("CFLAGS=-DHAVE_VPX_1_8") ;XXX: Remove for >1.14.
- #:phases
+ `(#:phases
(modify-phases %standard-phases
(add-after
'unpack 'disable-failing-tests
@@ -274,14 +272,14 @@ developers consider to have good quality code and correct functionality.")
(define-public gst-plugins-bad
(package
(name "gst-plugins-bad")
- (version "1.14.4")
+ (version "1.16.0")
(source (origin
(method url-fetch)
(uri (string-append "https://gstreamer.freedesktop.org/src/"
name "/" name "-" version ".tar.xz"))
(sha256
(base32
- "1r8dma3x127rbx42yab7kwq7q1bhkmvz2ykn0rnqnzl95q74w2wi"))))
+ "019b0yqjrcg6jmfd4cc336h1bz5p4wxl58yz1c4sdb96avirs4r2"))))
(outputs '("out" "doc"))
(build-system gnu-build-system)
(arguments
@@ -349,7 +347,7 @@ par compared to the rest.")
(define-public gst-plugins-ugly
(package
(name "gst-plugins-ugly")
- (version "1.14.4")
+ (version "1.16.0")
(source
(origin
(method url-fetch)
@@ -357,7 +355,7 @@ par compared to the rest.")
name "/" name "-" version ".tar.xz"))
(sha256
(base32
- "08vd1xgwmapnviah47zv5h2r02qdd20y4f07rvv5zhv6y4vxh0mc"))))
+ "1hm46c1fy9vl1wfwipsj41zp79cm7in1fpmjw24j5hriy32n82g3"))))
(build-system gnu-build-system)
(inputs
`(("gst-plugins-base" ,gst-plugins-base)
@@ -384,7 +382,7 @@ distribution problems in some jurisdictions, e.g. due to patent threats.")
(define-public gst-libav
(package
(name "gst-libav")
- (version "1.14.4")
+ (version "1.16.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -392,7 +390,7 @@ distribution problems in some jurisdictions, e.g. due to patent threats.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1nk5g24z2xx5kaw5cg8dv8skdc516inahmkymcz8bxqxj28qbmyz"))
+ "16ixqpfrr7plaaz14n3vagr2q5xbfkv7gpmcsyndrkx98f813b6z"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -407,7 +405,7 @@ distribution problems in some jurisdictions, e.g. due to patent threats.")
("python" ,python)))
(inputs
`(("gst-plugins-base" ,gst-plugins-base)
- ("ffmpeg" ,ffmpeg-3.4)
+ ("ffmpeg" ,ffmpeg)
("orc" ,orc)
("zlib" ,zlib)))
(home-page "https://gstreamer.freedesktop.org/")
@@ -420,7 +418,7 @@ compression formats through the use of the libav library.")
(define-public python-gst
(package
(name "python-gst")
- (version "1.14.4")
+ (version "1.16.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -428,7 +426,7 @@ compression formats through the use of the libav library.")
"gst-python-" version ".tar.xz"))
(sha256
(base32
- "06ssx19fs6pg4d32p9ph9w4f0xwmxaw2dxfj17rqkn5njd7v5zfh"))))
+ "0f1d9rvy2qxlymmfzyknnfr5rz1vx69jv17gp7wnamc5s6p7mp2m"))))
(build-system gnu-build-system)
(arguments
;; XXX: Factorize python-sitedir with python-build-system.
diff --git a/gnu/packages/patches/gst-plugins-good-libvpx-compat.patch b/gnu/packages/patches/gst-plugins-good-libvpx-compat.patch
deleted file mode 100644
index 8306c79e56..0000000000
--- a/gnu/packages/patches/gst-plugins-good-libvpx-compat.patch
+++ /dev/null
@@ -1,58 +0,0 @@
-Fix build with libvpx 1.8.
-
-Taken from this upstream commit:
-https://gitlab.freedesktop.org/gstreamer/gst-plugins-good/commit/b6e6f1ae73375ef66a5748069843aaed1a83e6a6
-
-Note: Remove the HAVE_VPX_1_8 build flag with this patch. It was added
-to avoid re-creating the configure script.
-
-diff --git a/configure.ac b/configure.ac
-index 5e4cff126..8c20e5081 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -1054,6 +1054,10 @@ AG_GST_CHECK_FEATURE(VPX, [VPX decoder], vpx, [
- AC_DEFINE(HAVE_VPX_1_4, 1, [Defined if the VPX library version is 1.4 or bigger])
- ], [true])
-
-+ PKG_CHECK_MODULES(VPX_180, vpx >= 1.8.0, [
-+ AC_DEFINE(HAVE_VPX_1_8, 1, [Defined if the VPX library version is 1.8 or bigger])
-+ ], [true])
-+
- LIBS="$OLD_LIBS"
- CFLAGS="$OLD_CFLAGS"
- fi
-diff --git a/ext/vpx/gstvpxdec.c b/ext/vpx/gstvpxdec.c
-index c3f0f625f..da4322513 100644
---- a/ext/vpx/gstvpxdec.c
-+++ b/ext/vpx/gstvpxdec.c
-@@ -62,6 +62,7 @@ gst_vpx_dec_post_processing_flags_get_type (void)
- {C_FLAGS (VP8_DEBLOCK), "Deblock", "deblock"},
- {C_FLAGS (VP8_DEMACROBLOCK), "Demacroblock", "demacroblock"},
- {C_FLAGS (VP8_ADDNOISE), "Add noise", "addnoise"},
-+#ifndef HAVE_VPX_1_8
- {C_FLAGS (VP8_DEBUG_TXT_FRAME_INFO),
- "Print frame information",
- "visualize-frame-info"},
-@@ -74,6 +75,7 @@ gst_vpx_dec_post_processing_flags_get_type (void)
- {C_FLAGS (VP8_DEBUG_TXT_RATE_INFO),
- "Print video rate info",
- "visualize-rate-info"},
-+#endif
- {C_FLAGS (VP8_MFQE), "Multi-frame quality enhancement", "mfqe"},
- {0, NULL, NULL}
- };
-diff --git a/ext/vpx/meson.build b/ext/vpx/meson.build
-index 6ed440728..0d2340b32 100644
---- a/ext/vpx/meson.build
-+++ b/ext/vpx/meson.build
-@@ -48,6 +48,10 @@ if vpx_dep.found()
- vpx_args += '-DHAVE_VPX_1_4'
- endif
-
-+ if dependency('vpx', version : '>=1.8.0', required : false).found()
-+ vpx_args += '-DHAVE_VPX_1_8'
-+ endif
-+
- gstvpx = library('gstvpx',
- vpx_sources,
- c_args : gst_plugins_good_args + vpx_args,