summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2021-10-18 18:08:57 +0000
committerLudovic Courtès <ludo@gnu.org>2021-11-16 16:59:51 +0100
commitc769b8c2b5bf97cf9aaaa9b151012763355b1f66 (patch)
tree36a5cf05cdedc471238d481278d5703dabe5e615 /gnu/packages
parent37db6db2841e7e5c9be54dd198964046a53d2c71 (diff)
downloadguix-patches-c769b8c2b5bf97cf9aaaa9b151012763355b1f66.tar
guix-patches-c769b8c2b5bf97cf9aaaa9b151012763355b1f66.tar.gz
gnu: aws-sdk-cpp: Update to 1.9.136.
* gnu/packages/cpp.scm (aws-sdk-cpp): Update to 1.9.136. [arguments]: Fix CMAKE_PREFIX_PATH. [source]: Remove patches. * gnu/packages/patches/aws-sdk-cpp-cmake-prefix.patch, gnu/packages/patches/aws-sdk-cpp-disable-network-tests.patch, gnu/packages/patches/aws-sdk-cpp-disable-werror.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Remove them. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cpp.scm17
-rw-r--r--gnu/packages/patches/aws-sdk-cpp-cmake-prefix.patch18
-rw-r--r--gnu/packages/patches/aws-sdk-cpp-disable-networking-tests.patch44
-rw-r--r--gnu/packages/patches/aws-sdk-cpp-disable-werror.patch11
4 files changed, 8 insertions, 82 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 53fa11beca..72bb5bcda5 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -943,7 +943,9 @@ aws-c-http, aws-c-io, aws-c-mqtt, aws-checksums, and s2n.")
(define-public aws-sdk-cpp
(package
(name "aws-sdk-cpp")
- (version "1.9.92")
+ ; When updating also check for a tagged update to aws-crt-cpp from
+ ; https://github.com/aws/aws-sdk-cpp/tree/main/crt
+ (version "1.9.136")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -952,19 +954,16 @@ aws-c-http, aws-c-io, aws-c-mqtt, aws-checksums, and s2n.")
(file-name (git-file-name name version))
(sha256
(base32
- "0nbq1qivykfg8jmrn8d0k6fcfa5dw9s90wnwddh7ia4zafmby7pd"))
- (patches
- (search-patches
- "aws-sdk-cpp-cmake-prefix.patch"
- "aws-sdk-cpp-disable-networking-tests.patch"
- "aws-sdk-cpp-disable-werror.patch"))))
+ "0ap7g7nmbnrcajy3b788bnpqd87dwmg83dhll1q8qzli04bcg47i"))))
(build-system cmake-build-system)
(arguments
'(;; Tests are run during the build phase.
#:tests? #f
#:configure-flags
- '("-DBUILD_SHARED_LIBS=ON"
- "-DBUILD_DEPS=OFF")))
+ (list "-DBUILD_DEPS=OFF"
+ "-DBUILD_SHARED_LIBS=ON"
+ (string-append "-DCMAKE_PREFIX_PATH="
+ (assoc-ref %build-inputs "aws-c-common")))))
(propagated-inputs
`(("aws-crt-cpp" ,aws-crt-cpp)))
(inputs
diff --git a/gnu/packages/patches/aws-sdk-cpp-cmake-prefix.patch b/gnu/packages/patches/aws-sdk-cpp-cmake-prefix.patch
deleted file mode 100644
index efc1218834..0000000000
--- a/gnu/packages/patches/aws-sdk-cpp-cmake-prefix.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -98,9 +98,13 @@ set(PYTHON_CMD "python")
- # CMAKE_MODULE_PATH is a CMAKE variable. It contains a list of paths
- # which could be used to search CMAKE modules by "include()" or "find_package()", but the default value is empty.
- # Add ${CMAKE_INSTALL_LIBDIR}/cmake and ${CMAKE_PREFIX_PATH}/lib/cmake to search list
-+if (DEFINED ENV{CMAKE_PREFIX_PATH})
-+ set(CMAKE_PREFIX_PATH $ENV{CMAKE_PREFIX_PATH})
-+endif()
-+
- list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_LIST_DIR}/cmake")
--set(AWS_MODULE_DIR "/${CMAKE_INSTALL_LIBDIR}/cmake")
--string(REPLACE ";" "${AWS_MODULE_DIR};" AWS_MODULE_PATH "${CMAKE_PREFIX_PATH}${AWS_MODULE_DIR}")
-+set(AWS_MODULE_DIR "${CMAKE_INSTALL_LIBDIR}/cmake")
-+string(REPLACE ":" "${AWS_MODULE_DIR};" AWS_MODULE_PATH "${CMAKE_PREFIX_PATH}${AWS_MODULE_DIR}")
- list(APPEND CMAKE_MODULE_PATH ${AWS_MODULE_PATH})
-
- # include() will "load and run" cmake script
diff --git a/gnu/packages/patches/aws-sdk-cpp-disable-networking-tests.patch b/gnu/packages/patches/aws-sdk-cpp-disable-networking-tests.patch
deleted file mode 100644
index 3b582d9628..0000000000
--- a/gnu/packages/patches/aws-sdk-cpp-disable-networking-tests.patch
+++ /dev/null
@@ -1,44 +0,0 @@
---- a/aws-cpp-sdk-core-tests/http/HttpClientTest.cpp
-+++ b/aws-cpp-sdk-core-tests/http/HttpClientTest.cpp
-@@ -92,12 +92,12 @@ TEST(HttpClientTest, TestRandomURLWithNoProxy)
- makeRandomHttpRequest(httpClient, false);
- }
-
--TEST(HttpClientTest, TestRandomURLWithProxy)
--{
-- ClientConfiguration configuration = makeClientConfigurationWithProxy();
-- auto httpClient = CreateHttpClient(configuration);
-- makeRandomHttpRequest(httpClient, true); // we expect it to try to use proxy that is invalid
--}
-+//TEST(HttpClientTest, TestRandomURLWithProxy)
-+//{
-+// ClientConfiguration configuration = makeClientConfigurationWithProxy();
-+// auto httpClient = CreateHttpClient(configuration);
-+// makeRandomHttpRequest(httpClient, true); // we expect it to try to use proxy that is invalid
-+//}
-
- TEST(HttpClientTest, TestRandomURLWithProxyAndDeclaredAsNonProxyHost)
- {
-@@ -119,14 +119,14 @@ TEST(HttpClientTest, TestRandomURLWithProxyAndDeclaredParentDomainAsNonProxyHost
- makeRandomHttpRequest(httpClient, false);
- }
-
--TEST(HttpClientTest, TestRandomURLWithProxyAndOtherDeclaredAsNonProxyHost)
--{
-- ClientConfiguration configuration = makeClientConfigurationWithProxy();
-- configuration.nonProxyHosts = Aws::Utils::Array<Aws::String>(1);
-- configuration.nonProxyHosts[0] = "http://test.non.filtered.aws";
-- auto httpClient = CreateHttpClient(configuration);
-- makeRandomHttpRequest(httpClient, true);
--}
-+//TEST(HttpClientTest, TestRandomURLWithProxyAndOtherDeclaredAsNonProxyHost)
-+//{
-+// ClientConfiguration configuration = makeClientConfigurationWithProxy();
-+// configuration.nonProxyHosts = Aws::Utils::Array<Aws::String>(1);
-+// configuration.nonProxyHosts[0] = "http://test.non.filtered.aws";
-+// auto httpClient = CreateHttpClient(configuration);
-+// makeRandomHttpRequest(httpClient, true);
-+//}
-
- // TODO: Pending Fix on Windows.
- #if ENABLE_CURL_CLIENT
diff --git a/gnu/packages/patches/aws-sdk-cpp-disable-werror.patch b/gnu/packages/patches/aws-sdk-cpp-disable-werror.patch
deleted file mode 100644
index 249c299239..0000000000
--- a/gnu/packages/patches/aws-sdk-cpp-disable-werror.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/cmake/compiler_settings.cmake
-+++ b/cmake/compiler_settings.cmake
-@@ -53,7 +53,7 @@ macro(set_gcc_flags)
- endmacro()
-
- macro(set_gcc_warnings)
-- list(APPEND AWS_COMPILER_WARNINGS "-Wall" "-Werror" "-pedantic" "-Wextra")
-+ list(APPEND AWS_COMPILER_WARNINGS "-Wall" "-pedantic" "-Wextra")
- if(COMPILER_CLANG)
- if(PLATFORM_ANDROID)
- # when using clang with libc and API lower than 21 we need to include Android support headers and ignore the gnu-include-next warning.