summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorAlex Kost <alezost@gmail.com>2016-06-21 16:29:40 +0300
committerAlex Kost <alezost@gmail.com>2016-06-22 11:16:05 +0300
commitc283b22e93cbf496e13b25878be3ec8a1242fb73 (patch)
tree4d42fb433dbc59e2b3e33e63f4c859fa56c3ff64 /gnu/packages
parent2831675bfd4d4ba78f6511cf7698ee745d1fbf33 (diff)
downloadguix-patches-c283b22e93cbf496e13b25878be3ec8a1242fb73.tar
guix-patches-c283b22e93cbf496e13b25878be3ec8a1242fb73.tar.gz
gnu: lightning: Move to (gnu packages assembly).
* gnu/packages/lightning.scm: Remove. Move 'lightning' to... * gnu/packages/assembly.scm (lightning): ... here. New variable. * gnu/local.mk (GNU_SYSTEM_MODULES): Adjust accordingly.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/assembly.scm22
-rw-r--r--gnu/packages/lightning.scm44
2 files changed, 22 insertions, 44 deletions
diff --git a/gnu/packages/assembly.scm b/gnu/packages/assembly.scm
index 8c9b6b30fe..c80b8af329 100644
--- a/gnu/packages/assembly.scm
+++ b/gnu/packages/assembly.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2013, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;;
@@ -90,3 +91,24 @@ Mach-O, RDOFF2, COFF, Win32, and Win64 object formats, and generates source
debugging information in STABS, DWARF 2, and CodeView 8 formats.")
(license (license:non-copyleft "file://COPYING"
"See COPYING in the distribution."))))
+
+(define-public lightning
+ (package
+ (name "lightning")
+ (version "2.1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/lightning/lightning-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "19j9nwl88k660045s40cbz5zrl1wpd2mcxnnc8qqnnaj311a58qz"))))
+ (build-system gnu-build-system)
+ (synopsis "Library for generating assembly code at runtime")
+ (description
+ "GNU Lightning is a library that generates assembly language code at
+run-time. Thus, it is useful in creating Just-In-Time compilers. It
+abstracts over the target CPU by exposing a standardized RISC instruction set
+to the clients.")
+ (home-page "http://www.gnu.org/software/lightning/")
+ (license gpl3+)))
diff --git a/gnu/packages/lightning.scm b/gnu/packages/lightning.scm
deleted file mode 100644
index 7dacb8f4cd..0000000000
--- a/gnu/packages/lightning.scm
+++ /dev/null
@@ -1,44 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu packages lightning)
- #:use-module (guix packages)
- #:use-module (guix download)
- #:use-module (guix build-system gnu)
- #:use-module (guix licenses))
-
-(define-public lightning
- (package
- (name "lightning")
- (version "2.1.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/lightning/lightning-"
- version ".tar.gz"))
- (sha256
- (base32
- "19j9nwl88k660045s40cbz5zrl1wpd2mcxnnc8qqnnaj311a58qz"))))
- (build-system gnu-build-system)
- (synopsis "Library for generating assembly code at runtime")
- (description
- "GNU Lightning is a library that generates assembly language code at
-run-time. Thus, it is useful in creating Just-In-Time compilers. It
-abstracts over the target CPU by exposing a standardized RISC instruction set
-to the clients.")
- (home-page "http://www.gnu.org/software/lightning/")
- (license gpl3+)))