summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-08-24 22:49:25 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-08-25 13:03:13 +0300
commitc15692b938e04ad253d9bbfe127e8fd3deb85b6f (patch)
tree984f5fd2be4e3331065973b8376c8881ced2cae0 /gnu/packages
parent87720306307dc4297435d45c43c9b326907b1415 (diff)
downloadguix-patches-c15692b938e04ad253d9bbfe127e8fd3deb85b6f.tar
guix-patches-c15692b938e04ad253d9bbfe127e8fd3deb85b6f.tar.gz
gnu: go-github-com-sirupsen-logrus: Skip tests with gccgo.
* gnu/packages/golang.scm (go-github-com-sirupsen-logrus)[arguments]: Don't run the test suite when building with gccgo.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang.scm13
1 files changed, 11 insertions, 2 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 45f1150fb7..f31fb4105d 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3812,12 +3812,21 @@ application's http.Handlers.")
(base32
"12i402dxq5js4npnncg043vx874h6nk4ffn4gswcccxrp6h10ivz"))))
(build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/sirupsen/logrus"
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs #:allow-other-keys #:rest args)
+ (unless
+ ;; The tests fail when run with gccgo.
+ (false-if-exception (search-input-file inputs "/bin/gccgo"))
+ (apply (assoc-ref %standard-phases 'check) args)))))))
(propagated-inputs
(list go-github-com-davecgh-go-spew go-github-com-pmezard-go-difflib
go-github-com-stretchr-testify go-golang-org-x-crypto
go-golang-org-x-sys))
- (arguments
- '(#:import-path "github.com/sirupsen/logrus"))
(home-page "https://github.com/sirupsen/logrus")
(synopsis "Structured, pluggable logging for Go")
(description "Logrus is a structured logger for Go, completely API