summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2020-07-23 15:23:23 -0300
committerMarius Bakke <marius@gnu.org>2020-07-25 18:47:56 +0200
commitc0f52c41d86744537075229a9f0ec0f77ced0c75 (patch)
tree5b557992443ba9f5d71e0e166ee799be6586413d /gnu/packages
parentcd09634ad52e6f32d85af71e0410ab4e2b6eaed9 (diff)
downloadguix-patches-c0f52c41d86744537075229a9f0ec0f77ced0c75.tar
guix-patches-c0f52c41d86744537075229a9f0ec0f77ced0c75.tar.gz
gnu: Add python-pytest-arraydiff.
* gnu/packages/python-check.scm (python-pytest-arraydiff): New variable. Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-check.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 2e3cfe05c5..9d25753f70 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2020 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020 Edouard Klein <edk@beaver-labs.com>
+;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -125,6 +126,32 @@ detect the absence of a cassette file and once again record all HTTP
interactions, which will update them to correspond to the new API.")
(license license:expat)))
+(define-public python-pytest-arraydiff
+ (package
+ (name "python-pytest-arraydiff")
+ (version "0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-arraydiff" version))
+ (sha256
+ (base32 "05bcvhh2ycxa35znl8b3l9vkcmx7vwm5c3fpakbpw46c7vsn4bfy"))))
+ (build-system python-build-system)
+ (arguments
+ ;; Tests require python-astropy, which itself requires this package.
+ ;; Disable tests to avoid the circular dependency problem.
+ '(#:tests? #f))
+ (propagated-inputs
+ `(("python-numpy" ,python-numpy)
+ ("python-six" ,python-six)))
+ (home-page "https://github.com/astropy/pytest-arraydiff")
+ (synopsis "Pytest plugin to help with comparing array output from tests")
+ (description
+ "This is a py.test plugin to facilitate the generation and comparison of
+data arrays produced during tests, in particular in cases where the arrays
+are too large to conveniently hard-code them in the tests.")
+ (license license:bsd-3)))
+
(define-public python-pytest-vcr
;; This commit fixes integration with pytest-5
(let ((commit "4d6c7b3e379a6a7cba0b8f9d20b704dc976e9f05")