summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2016-07-28 23:38:31 +0200
committerLeo Famulari <leo@famulari.name>2016-08-08 22:36:39 -0400
commitbe0c57338adb60b323ff0d3c757437e1fa70ca01 (patch)
tree3c742ff2dc497957e413a6dd2bd856f2a0fba605 /gnu/packages
parentadff71ca5c4b422afd49d340d7eb950ec919b1c4 (diff)
downloadguix-patches-be0c57338adb60b323ff0d3c757437e1fa70ca01.tar
guix-patches-be0c57338adb60b323ff0d3c757437e1fa70ca01.tar.gz
gnu: Add perl-mail-spf.
* gnu/package/mail.scm (perl-mail-spf): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/mail.scm45
1 files changed, 44 insertions, 1 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 03ba3ead5b..4775e3eb7d 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -71,11 +71,13 @@
#:use-module (gnu packages gdb)
#:use-module (gnu packages samba)
#:use-module (gnu packages tls)
+ #:use-module (gnu packages networking)
+ #:use-module (gnu packages web)
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
#:use-module ((guix licenses)
#:select (gpl2 gpl2+ gpl3 gpl3+ lgpl2.1 lgpl2.1+ lgpl3+
- non-copyleft (expat . license:expat)))
+ non-copyleft (expat . license:expat) bsd-3))
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix git-download)
@@ -1261,3 +1263,44 @@ synchronizing with a remote address book, @command{vdirsyncer} is recommended.
Khard can also be used from within the email client @command{mutt}.")
(home-page "https://github.com/scheibler/khard")
(license gpl3+)))
+
+(define-public perl-mail-spf
+ (package
+ (name "perl-mail-spf")
+ (version "v2.9.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/J/JM/JMEHNLE/mail-spf/Mail-SPF-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0qk1rfgfm5drj4iyniiabrasrpqv570vzhgz66lwgb67y4amkjv1"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-module-build" ,perl-module-build)
+ ("perl-net-dns-resolver-programmable"
+ ,perl-net-dns-resolver-programmable)))
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (add-before 'configure 'modify-Build.PL
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "Build.PL"
+ (("'/usr/sbin'") (string-append "'"
+ (assoc-ref outputs "out")
+ "/sbin'")))
+ #t)))))
+ (inputs
+ `(("perl-error" ,perl-error)
+ ("perl-net-dns" ,perl-net-dns)
+ ("perl-netaddr-ip" ,perl-netaddr-ip)
+ ("perl-uri" ,perl-uri)))
+ (home-page
+ "http://search.cpan.org/dist/Mail-SPF")
+ (synopsis
+ "Perl implementation of Sender Policy Framework")
+ (description "Mail::SPF is the Sender Policy Framework implemented
+in Perl.")
+ (license bsd-3)))