summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-04-20 05:22:27 +0000
committerLars-Dominik Braun <lars@6xq.net>2021-05-08 11:27:48 +0200
commitbd6f03846b3623f5ce9272bddad221d13093f923 (patch)
treea08e42777f1611d7a5d137dd87434cff41aa2d5e /gnu/packages
parent796f7cabdb5d71e217a760b4d122147cd9c74993 (diff)
downloadguix-patches-bd6f03846b3623f5ce9272bddad221d13093f923.tar
guix-patches-bd6f03846b3623f5ce9272bddad221d13093f923.tar.gz
gnu: Add python-three-merge.
* gnu/packages/python-xyz.scm (python-three-merge): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f2437f3208..24a49685c7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8476,6 +8476,40 @@ solve linear problems.")
algorithm.")
(license license:asl2.0)))
+(define-public python-three-merge
+ (package
+ (name "python-three-merge")
+ (version "0.1.1")
+ (source
+ (origin
+ ;; There are no tests in the PyPI tarball.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/spyder-ide/three-merge")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1fw28swh6jq4myr09j7gv68l241b8vwg470ak5xv0x4xwh2a1m86"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:test-target "pytest"))
+ (propagated-inputs
+ `(("python-diff-match-patch" ,python-diff-match-patch)))
+ (native-inputs
+ `(("python-flaky" ,python-flaky)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-pytest-runner" ,python-pytest-runner)
+ ("python-pytest-timeout" ,python-pytest-timeout)))
+ (home-page "https://github.com/spyder-ide/three-merge")
+ (synopsis "Library for merging two strings with respect to a base one")
+ (description
+ "This package provides a Python library to perform a 3-way merge between
+strings, based on @code{diff-match-patch}. This library performs merges at a
+character level, as opposed to most VCS systems, which opt for a line-based
+approach.")
+ (license license:expat)))
+
(define-public snakemake
(package
(name "snakemake")