summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2020-08-28 15:54:06 +0200
committerAndreas Enge <andreas@enge.fr>2020-08-28 16:29:04 +0200
commitb9f3046eaa21387d7ff4a14574a7ebd0c46e10d9 (patch)
tree8eb80f6bd93268004f7eb8bd883cf7fce176ac11 /gnu/packages
parent3b3cc55335ab6e3fd92e66b08a218019213bd89b (diff)
downloadguix-patches-b9f3046eaa21387d7ff4a14574a7ebd0c46e10d9.tar
guix-patches-b9f3046eaa21387d7ff4a14574a7ebd0c46e10d9.tar.gz
gnu: Add python-purl.
* gnu/packages/python-web.scm (python-purl): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-web.scm23
1 files changed, 22 insertions, 1 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index e43c6f7aba..b419c03f7f 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Christopher Baines <mail@cbaines.net>
;;; Copyright © 2016, 2017 Danny Milosavljevic <dannym+a@scratchpost.org>
-;;; Copyright © 2013, 2014, 2015, 2016 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2013, 2014, 2015, 2016, 2020 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016, 2017, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017 Roel Janssen <roel@gnu.org>
@@ -1856,6 +1856,27 @@ WebSocket usage in Python programs.")
,python2-backport-ssl-match-hostname)
,@(package-native-inputs base))))))
+(define-public python-purl
+ (package
+ (name "python-purl")
+ (version "1.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "purl" version))
+ (sha256
+ (base32
+ "15ibnz1xrh5msmn04j0nr00sz4n7jwx6cwd6zlx99kkz3vpin53m"))))
+ (build-system python-build-system)
+ (propagated-inputs `(("python-six" ,python-six)))
+ (home-page
+ "https://github.com/codeinthehole/purl")
+ (synopsis
+ "Python package for URL manipulation")
+ (description
+ "Purl is a Python package for handling URLs.")
+ (license license:expat)))
+
(define-public python-requests
(package
(name "python-requests")