summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2020-07-24 09:01:42 -0300
committerMarius Bakke <marius@gnu.org>2020-07-25 18:47:57 +0200
commitb8bf0f8c2ce8931298bb810e747836acfb06011c (patch)
treeff9b77a49aa53d168a4730d5955d1bd8b47982a9 /gnu/packages
parent48443dc8805fc398a1108dbde86e077b0646cf30 (diff)
downloadguix-patches-b8bf0f8c2ce8931298bb810e747836acfb06011c.tar
guix-patches-b8bf0f8c2ce8931298bb810e747836acfb06011c.tar.gz
gnu: Add python-nodeenv.
* gnu/packages/python-xyz.scm (python-nodeenv): New variable. Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 031ce91885..446e0a6def 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17555,6 +17555,41 @@ Public Suffix List's private domains as well.")
(define-public python2-tldextract
(package-with-python2 python-tldextract))
+(define-public python-nodeenv
+ (package
+ (name "python-nodeenv")
+ (version "1.4.0")
+ (source
+ (origin
+ ;; There's no tarball in PyPI.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ekalinin/nodeenv")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0y443icx0w7jlzmxmmcm4q8dqfiwgafbb9cp8jpm68mbqxbz40a7"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ ;; This test fails. It tries to open a network socket.
+ (invoke "pytest" "-vv" "-k" "not test_smoke"))))))
+ (native-inputs
+ `(("python-coverage" ,python-coverage)
+ ("python-mock" ,python-mock)
+ ("python-pytest" ,python-pytest)))
+ (home-page "https://ekalinin.github.io/nodeenv/")
+ (synopsis "Create isolated node.js environments")
+ (description
+ "Nodeenv (node.js virtual environment) is a tool to create isolated
+node.js environments. It creates an environment that has its own installation
+directories, that doesn't share libraries with other node.js virtual
+environments.")
+ (license license:bsd-3)))
+
(define-public python-pynamecheap
(package
(name "python-pynamecheap")