summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-10-16 20:27:53 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-15 22:31:39 +0100
commitb83e23337bcd13b880e3f8bacc371815efec4633 (patch)
treecc03f6f9c5e34bf59d3485798143e7af86fd611e /gnu/packages
parent9fbe7b2bca101835b2e456af1aecd2be9ec9f182 (diff)
downloadguix-patches-b83e23337bcd13b880e3f8bacc371815efec4633.tar
guix-patches-b83e23337bcd13b880e3f8bacc371815efec4633.tar.gz
gnu: python-scikit-image: Correct inputs.
* gnu/packages/python.scm: (python-scikit-image, python2-scikit-image) [propagated-inputs]: Move python-numpy and python-six to [native-inputs]. Add comment.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 88d99710ac..f3ac670f9f 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2960,15 +2960,16 @@ mining and data analysis.")
(sha256
(base32 "0jz416fqvpahqyffw8plmszzfj669w8wvf3y9clnr5lr6a7md3kn"))))
(build-system python-build-system)
+ ;; See DEPENDS.txt for the list of build and run time requiremnts
(propagated-inputs
`(("python-matplotlib" ,python-matplotlib)
("python-networkx" ,python-networkx)
- ("python-numpy" ,python-numpy)
("python-scipy" ,python-scipy)
- ("python-six" ,python-six)
("python-pillow" ,python-pillow)))
(native-inputs
- `(("python-cython" ,python-cython)))
+ `(("python-numpy" ,python-numpy)
+ ("python-cython" ,python-cython)
+ ("python-six" ,python-six)))
(home-page "http://scikit-image.org/")
(synopsis "Image processing in Python")
(description