summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-07-09 16:20:38 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-07-09 17:07:39 +0200
commitb81dd94a790636fea9ac59ad1c63d78420fad54a (patch)
tree1e79bda04e53aec091d373d6c7debf450e34705a /gnu/packages
parentf45a5520383e227c9e3f5c106595e623f742b43f (diff)
downloadguix-patches-b81dd94a790636fea9ac59ad1c63d78420fad54a.tar
guix-patches-b81dd94a790636fea9ac59ad1c63d78420fad54a.tar.gz
gnu: dblatex: Use texlive-union.
* gnu/packages/patches/dblatex-remove-multirow.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/docbook.scm (dblatex)[source]: Use patch. [inputs]: Replace "texlive" with a texlive-union.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/docbook.scm34
-rw-r--r--gnu/packages/patches/dblatex-remove-multirow.patch30
2 files changed, 62 insertions, 2 deletions
diff --git a/gnu/packages/docbook.scm b/gnu/packages/docbook.scm
index 7a309b0bc9..189ece01ab 100644
--- a/gnu/packages/docbook.scm
+++ b/gnu/packages/docbook.scm
@@ -180,11 +180,41 @@ by no means limited to these applications.) This package provides XML DTDs.")
version ".tar.bz2"))
(sha256
(base32
- "0pdizc5rjywwzxa1qqhdmba5zr35pbmdwbysalsid7xw87w3kq06"))))
+ "0pdizc5rjywwzxa1qqhdmba5zr35pbmdwbysalsid7xw87w3kq06"))
+ (patches (search-patches "dblatex-remove-multirow.patch"))))
(build-system python-build-system)
;; TODO: Add xfig/transfig for fig2dev utility
(inputs
- `(("texlive" ,texlive)
+ `(("texlive" ,(texlive-union (list texlive-latex-amsfonts
+ texlive-latex-anysize
+ texlive-latex-appendix
+ texlive-latex-changebar
+ texlive-latex-colortbl
+ texlive-latex-eepic
+ texlive-latex-eso-pic
+ texlive-latex-fancybox
+ texlive-latex-fancyhdr
+ texlive-latex-fancyvrb
+ texlive-latex-float
+ texlive-latex-footmisc
+ texlive-latex-hyperref
+ texlive-latex-jknapltx
+ texlive-latex-listings
+ texlive-latex-multirow
+ texlive-latex-oberdiek
+ texlive-latex-overpic
+ texlive-latex-pdfpages
+ texlive-latex-subfigure
+ texlive-latex-titlesec
+ texlive-latex-url
+ texlive-latex-wasysym
+
+ texlive-fonts-amsfonts
+ texlive-fonts-ec
+ texlive-fonts-rsfs
+ texlive-fonts-stmaryrd
+
+ texlive-generic-ifxetex)))
("imagemagick" ,imagemagick) ;for convert
("inkscape" ,inkscape) ;for svg conversion
("docbook" ,docbook-xml)
diff --git a/gnu/packages/patches/dblatex-remove-multirow.patch b/gnu/packages/patches/dblatex-remove-multirow.patch
new file mode 100644
index 0000000000..62d1c64e08
--- /dev/null
+++ b/gnu/packages/patches/dblatex-remove-multirow.patch
@@ -0,0 +1,30 @@
+This patch is needed to fix dblatex with newer versions of TeX Live.
+It was taken from https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=840189
+
+--- a/latex/style/dbk_table.sty Sun Oct 02 23:21:03 2016 +0200
++++ b/latex/style/dbk_table.sty Mon Oct 10 21:31:00 2016 +0200
+@@ -9,7 +9,6 @@
+ \usepackage{longtable}
+ \usepackage{lscape}
+ \usepackage{colortbl}
+-\usepackage{multirow}
+ \usepackage{calc}
+ \usepackage{hhline}
+
+@@ -21,16 +20,6 @@
+ \expandafter[\expandafter3\expandafter]\expandafter{%
+ \multicolumn{#1}{#2}{#3}}
+
+-% Make \@xmultirow long
+-\expandafter\long\expandafter\def%
+-\expandafter\@xmultirow%
+-\expandafter#\expandafter1%
+-\expandafter[\expandafter#\expandafter2\expandafter]%
+-\expandafter#\expandafter3%
+-\expandafter[\expandafter#\expandafter4\expandafter]%
+-\expandafter#\expandafter5%
+-\expandafter{\@xmultirow{#1}[#2]{#3}[#4]{#5}}
+-
+ % For the newtbl code
+ \newdimen\newtblstarfactor%
+ \newdimen\newtblsparewidth%