summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2020-03-06 13:49:40 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2020-03-06 13:51:52 +0100
commitb4335cfb55ced138ce07cf5d0a29c06fa6e6d1c5 (patch)
treea0772fac3729caa9fecfdf63637fb91bb3654976 /gnu/packages
parent92594b2e0fdae039b9149bcf82b829294ab45fef (diff)
downloadguix-patches-b4335cfb55ced138ce07cf5d0a29c06fa6e6d1c5.tar
guix-patches-b4335cfb55ced138ce07cf5d0a29c06fa6e6d1c5.tar.gz
gnu: guix: Fix cross-compilation.
* gnu/packages/package-management.scm (guix)[native-inputs]: Add all Guile libraries to fix cross-compilation.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/package-management.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index c872a563fe..6daad079b3 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2018, 2019 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2019 Jonathan Brielmaier <jonathan.brielmaier@web.de>
+;;; Copyright © 2020 Mathieu Othacehe <m.othacehe@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -277,6 +278,16 @@
#t))))))
(native-inputs `(("pkg-config" ,pkg-config)
+ ;; Guile libraries are needed here for
+ ;; cross-compilation.
+ ("guile" ,guile-2.2)
+ ("gnutls" ,gnutls)
+ ("guile-gcrypt" ,guile-gcrypt)
+ ("guile-json" ,guile-json-3)
+ ("guile-sqlite3" ,guile-sqlite3)
+ ("guile-ssh" ,guile-ssh)
+ ("guile-git" ,guile-git)
+
;; XXX: Keep the development inputs here even though
;; they're unnecessary, just so that 'guix environment
;; guix' always contains them.