summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-07-12 13:27:14 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-07-12 17:39:56 +0300
commitaba4cdc87f1146ccb018d73816d4ec950865a9ae (patch)
treefc5b4a41e8d8269f57abd70a8ea2f013c9244d6f /gnu/packages
parent908b680a5f213620c19c157223b45ccf3e534ade (diff)
downloadguix-patches-aba4cdc87f1146ccb018d73816d4ec950865a9ae.tar
guix-patches-aba4cdc87f1146ccb018d73816d4ec950865a9ae.tar.gz
gnu: python-tornado-6: Honor tests flag.
* gnu/packages/python-web.scm (python-tornado-6)[arguments]: Adjust custom 'check phase to honor the #:tests? flag.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-web.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 6f951595c8..87e65f4d36 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2073,9 +2073,9 @@ connection to each user.")
'(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda _
- (invoke "python" "-m" "tornado.test.runtests")
- #t)))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "python" "-m" "tornado.test.runtests")))))))
(native-inputs
(list python-certifi))
(home-page "https://www.tornadoweb.org/")