summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-07-26 14:48:51 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-07-26 15:20:26 +0300
commitab751d5320b74e088f9e71d2ad3fd31fd73ae1bf (patch)
tree788b04c557d3b86ee8bb6b8b9bfa92381d2de69a /gnu/packages
parentebd1ba713cbefc9ad5dac609255e1344a328e360 (diff)
downloadguix-patches-ab751d5320b74e088f9e71d2ad3fd31fd73ae1bf.tar
guix-patches-ab751d5320b74e088f9e71d2ad3fd31fd73ae1bf.tar.gz
gnu: Add xclickroot.
* gnu/packages/wm.scm (xclickroot): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/wm.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index a087457d30..e6cb197e92 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1892,3 +1892,35 @@ bar entirely based on XCB. Provides full UTF-8 support, basic
formatting, RandR and Xinerama support and EWMH compliance without
wasting your precious memory.")
(license license:x11))))
+
+(define-public xclickroot
+ (let ((commit "309fd17174dba4149b5ea66654c6fd02cfcf7c9a")
+ (revision "1"))
+ (package
+ (name "xclickroot")
+ (version (git-version "0.0.1" revision commit)) ;no upstream release
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/phillbush/xclickroot")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0fjqkg3wnyks0my1vrzhxfjicsfy8xwnijaazmpz6mhilcqkpvnd"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("libx11" ,libx11)))
+ (arguments
+ `(#:tests? #f ;no test suite
+ #:make-flags
+ (list ,(string-append "CC=" (cc-for-target))
+ (string-append "PREFIX=" %output))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "https://github.com/phillbush/xclickroot")
+ (synopsis "Run a command when a mouse button is pressed on the root window")
+ (description "@code{xclickroot} runs a command every time a given mouse
+button is pressed on the root window.")
+ (license license:public-domain))))