summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorKei Kebreau <kei@openmailbox.org>2017-04-22 13:57:55 -0400
committerKei Kebreau <kei@openmailbox.org>2017-04-22 13:57:55 -0400
commita7086b154f3a85e0ee75a582d58bc1e0a0fccc9a (patch)
tree0db70e5e8831621d06c8b756a81b7653c2e8045d /gnu/packages
parent7d873e0c2690bf5742cf41b001af906ebbecde37 (diff)
downloadguix-patches-a7086b154f3a85e0ee75a582d58bc1e0a0fccc9a.tar
guix-patches-a7086b154f3a85e0ee75a582d58bc1e0a0fccc9a.tar.gz
gnu: hyperrogue: Update to 9.4g.
* gnu/packages/games.scm (hyperrogue): Update to 9.4g.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/games.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index f6b4e3f0bf..18ea6148c8 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -3173,7 +3173,7 @@ throwing people around in pseudo-randomly generated buildings.")
(define-public hyperrogue
(package
(name "hyperrogue")
- (version "9.4c")
+ (version "9.4g")
;; When updating this package, be sure to update the "hyperrogue-data"
;; origin in native-inputs.
(source (origin
@@ -3184,7 +3184,7 @@ throwing people around in pseudo-randomly generated buildings.")
"-src.tgz"))
(sha256
(base32
- "1ri5fllnhqjm3dlnl1xbb9mlv79iigc940vbvcnk0v5k6p58pavq"))))
+ "09j9gnx701x28zfkrv3rjqlr56p89hyxk78gkpmmdfjgcq076pc2"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no check target
@@ -3239,14 +3239,14 @@ throwing people around in pseudo-randomly generated buildings.")
(string-append
"hyperrogue"
(string-join (string-split ,version #\.) "")
- "-win/sounds/credits.txt") "-d" sounds))
+ "/sounds/credits.txt") "-d" sounds))
;; Extract sounds and music into sounds directory.
(zero?
(system* "unzip" "-j" data
(string-append
"hyperrogue"
(string-join (string-split ,version #\.) "")
- "-win/*.ogg") "-d" sounds)))))))))
+ "/*.ogg") "-d" sounds)))))))))
(native-inputs
`(("hyperrogue-data"
,(origin
@@ -3258,7 +3258,7 @@ throwing people around in pseudo-randomly generated buildings.")
"-win.zip"))
(sha256
(base32
- "1cyyrsnrixygg3zyz97hpsm6jzwbhydiwk3kl0lm7qjnw2nzkhhh"))))
+ "1r57db4hm7fjcd27p8b6cdsnq2cgkym2kp9lrw7ha2asdf8w6gkb"))))
("unzip" ,unzip)))
(inputs
`(("font-dejavu" ,font-dejavu)