summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2016-07-29 15:58:06 -0400
committerMark H Weaver <mhw@netris.org>2016-07-29 18:28:40 -0400
commit9bdf56dc1349d1759fc670ff8715de25de0f0a9c (patch)
tree5ee8bdd52e5b87c34cd38c45072bb48a1c4e65ba /gnu/packages
parentde30a6e0f0c5fdb27dfac5460e8efda1408667a4 (diff)
downloadguix-patches-9bdf56dc1349d1759fc670ff8715de25de0f0a9c.tar
guix-patches-9bdf56dc1349d1759fc670ff8715de25de0f0a9c.tar.gz
gnu: gd: Add fix for gd2_read test.
* gnu/packages/patches/gd-fix-gd2-read-test.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/gd.scm (gd)[source]: Add patch.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gd.scm3
-rw-r--r--gnu/packages/patches/gd-fix-gd2-read-test.patch14
2 files changed, 16 insertions, 1 deletions
diff --git a/gnu/packages/gd.scm b/gnu/packages/gd.scm
index 153e1c7f8b..b1bbc22cd7 100644
--- a/gnu/packages/gd.scm
+++ b/gnu/packages/gd.scm
@@ -50,7 +50,8 @@
(sha256
(base32
"0g3xz8jpz1pl2zzmssglrpa9nxiaa7rmcmvgpbrjz8k9cyynqsvl"))
- (patches (search-patches "gd-fix-tests-on-i686.patch"))))
+ (patches (search-patches "gd-fix-gd2-read-test.patch"
+ "gd-fix-tests-on-i686.patch"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
diff --git a/gnu/packages/patches/gd-fix-gd2-read-test.patch b/gnu/packages/patches/gd-fix-gd2-read-test.patch
new file mode 100644
index 0000000000..65f39e4426
--- /dev/null
+++ b/gnu/packages/patches/gd-fix-gd2-read-test.patch
@@ -0,0 +1,14 @@
+Fix a 'maybe-uninitialized' warning (turned error)
+which occurs on non-Intel platforms.
+
+--- libgd-2.2.3/tests/gd2/gd2_read.c 2016-07-21 01:21:16.000000000 -0400
++++ libgd-2.2.3/tests/gd2/gd2_read.c 2016-07-29 15:52:03.806405312 -0400
+@@ -5,7 +5,7 @@
+
+ int main(int argc, char *argv[])
+ {
+- int error, i = 0;
++ int error = 0, i = 0;
+ gdImagePtr im, exp;
+ FILE *fp;
+ char *path[] = {