summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2014-11-23 13:07:42 +0800
committerLudovic Courtès <ludo@gnu.org>2014-11-24 21:52:39 +0100
commit98e9e22febf5284ec4d74dbb690429368bd2508d (patch)
tree3871a309bcd917b57ab6bd265d0cbb490caeb166 /gnu/packages
parent20dd519cdbb93799f6e4edc2fb39d6f6aa5b81c0 (diff)
downloadguix-patches-98e9e22febf5284ec4d74dbb690429368bd2508d.tar
guix-patches-98e9e22febf5284ec4d74dbb690429368bd2508d.tar.gz
gnu: Add getmail.
* gnu/packages/mail.scm (getmail): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/mail.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 46c24092e5..14e85be387 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014 Ian Denhardt <ian@zenhack.net>
+;;; Copyright © 2014 Sou Bunnbu <iyzsong@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -365,4 +366,31 @@ attachments, create new maildirs, and so on.")
ing, and tagging large collections of email messages.")
(license gpl3+)))
+(define-public getmail
+ (package
+ (name "getmail")
+ (version "4.46.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://pyropus.ca/software/getmail/old-versions/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "15rqmm25pq6ll8aaqh8h6pfdkpqs7y6yismb3h3w1bz8j292c8zl"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:python ,python-2))
+ (home-page "http://pyropus.ca/software/getmail/")
+ (synopsis "Mail retriever")
+ (description
+ "A flexible, extensible mail retrieval system with support for
+POP3, IMAP4, SSL variants of both, maildirs, mboxrd files, external MDAs,
+arbitrary message filtering, single-user and domain-mailboxes, and many other
+useful features.")
+
+ ;; License is specified in file '__init__.py'.
+ (license gpl2)))
+
;;; mail.scm ends here