summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-07-14 18:13:34 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-07-14 18:13:34 +0200
commit97149c576762de7fd8e1a6ac8f46c97d3490b360 (patch)
tree971fee6c4be8c3d7a43dbc46bb4509f2b6081213 /gnu/packages
parentad60a3484c6d3221b78dbc6f173ce27bc3b1f96a (diff)
downloadguix-patches-97149c576762de7fd8e1a6ac8f46c97d3490b360.tar
guix-patches-97149c576762de7fd8e1a6ac8f46c97d3490b360.tar.gz
gnu: Adjust uses of C{,PLUS}_INCLUDE_PATH for GCC 7.
These variables are no longer set in the build environment by default. GCC still respects these search paths and treats them as "system headers" so we can continue to use them, just not expect them to be available. * gnu/packages/mpi.scm (openmpi)[arguments]: Do not attempt to read from C_INCLUDE_PATH, nor CPLUS_INCLUDE_PATH. * gnu/packages/games.scm (kiki)[arguments]: Likewise. * gnu/packages/networking.scm (hcxtools)[arguments]: Likewise. * gnu/packages/synergy.scm (synergy)[arguments]: Likewise. * gnu/packages/bioinformatics.scm (gemma, sailfish)[arguments]: Likewise. * gnu/packages/maths.scm (dune-alugrid)[arguments]: Likewise.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioinformatics.scm8
-rw-r--r--gnu/packages/games.scm3
-rw-r--r--gnu/packages/maths.scm3
-rw-r--r--gnu/packages/mpi.scm6
-rw-r--r--gnu/packages/networking.scm3
-rw-r--r--gnu/packages/synergy.scm3
6 files changed, 8 insertions, 18 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 92bc532196..0dcbb94666 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3260,9 +3260,7 @@ comment or quality sections.")
(lambda* (#:key inputs #:allow-other-keys)
;; Ensure that Eigen headers can be found
(setenv "CPLUS_INCLUDE_PATH"
- (string-append (getenv "CPLUS_INCLUDE_PATH")
- ":"
- (assoc-ref inputs "eigen")
+ (string-append (assoc-ref inputs "eigen")
"/include/eigen3"))
#t))
(add-before 'build 'bin-mkdir
@@ -11697,9 +11695,7 @@ bytes of memory space, where n is the length of the string.")
;; Ensure that Eigen headers can be found
(setenv "CPLUS_INCLUDE_PATH"
- (string-append (getenv "CPLUS_INCLUDE_PATH")
- ":"
- (assoc-ref inputs "eigen")
+ (string-append (assoc-ref inputs "eigen")
"/include/eigen3"))
#t)))))
(inputs
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index b6a63aba02..6e54abc5d0 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -4175,8 +4175,7 @@ over 100 user-created campaigns.")
(string-append (assoc-ref inputs "sdl-union")
"/include/SDL:"
(assoc-ref inputs "python")
- "/include/python2.7:"
- (getenv "CPLUS_INCLUDE_PATH")))
+ "/include/python2.7"))
(substitute* "src/main/main.cpp"
(("#include <SDL.h>" line)
(string-append line "
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index df8bad13e0..3f9cd8be6e 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -4740,8 +4740,7 @@ assemble global function spaces on finite-element grids.")
(add-after 'build 'build-tests
(lambda* (#:key inputs make-flags #:allow-other-keys)
(setenv "CPLUS_INCLUDE_PATH"
- (string-append (assoc-ref inputs "dune-grid") "/share:"
- (getenv "CPLUS_INCLUDE_PATH")))
+ (string-append (assoc-ref inputs "dune-grid") "/share"))
(apply invoke "make" "build_tests" make-flags))))))
(inputs
`(("dune-common" ,dune-common)
diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index c9cd7b1382..c02e1d2e2b 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -217,12 +217,10 @@ bind processes, and much more.")
(lambda* (#:key inputs #:allow-other-keys)
(setenv "C_INCLUDE_PATH"
(string-append (assoc-ref inputs "opensm")
- "/include/infiniband/:"
- (getenv "C_INCLUDE_PATH")))
+ "/include/infiniband"))
(setenv "CPLUS_INCLUDE_PATH"
(string-append (assoc-ref inputs "opensm")
- "/include/infiniband/:"
- (getenv "CPLUS_INCLUDE_PATH")))
+ "/include/infiniband"))
#t))
(add-before 'build 'remove-absolute
(lambda _
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 53c11f6d95..ce9afaf16d 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2289,8 +2289,7 @@ Ethernet and TAP interfaces is supported. Packet capture is also supported.")
(string-append (assoc-ref inputs "curl") "/include:"
(assoc-ref inputs "libpcap") "/include:"
(assoc-ref inputs "openssl") "/include:"
- (assoc-ref inputs "zlib") "/include:"
- (getenv "C_INCLUDE_PATH")))
+ (assoc-ref inputs "zlib") "/include"))
#t)))))
(home-page "https://github.com/ZerBea/hcxtools")
(synopsis "Capture wlan traffic to hashcat and John the Ripper")
diff --git a/gnu/packages/synergy.scm b/gnu/packages/synergy.scm
index da8787285f..9de3ee57e4 100644
--- a/gnu/packages/synergy.scm
+++ b/gnu/packages/synergy.scm
@@ -63,8 +63,7 @@
(lambda* (#:key inputs #:allow-other-keys)
(setenv "CPLUS_INCLUDE_PATH"
(string-append (assoc-ref inputs "avahi")
- "/include/avahi-compat-libdns_sd/:"
- (getenv "CPLUS_INCLUDE_PATH")))
+ "/include/avahi-compat-libdns_sd"))
;; See https://github.com/symless/synergy-core/pull/6359/
(substitute* "src/gui/src/ScreenSetupView.cpp"
(("#include <QtGui>" m)