summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2019-04-23 20:14:16 +0530
committerArun Isaac <arunisaac@systemreboot.net>2019-04-23 22:06:45 +0530
commit9694b44e3b8aaac230c2ae8c8ddcf676ba19a1d7 (patch)
treeee90a269a3a2cc051b4f4e6d0cfdbc890c4f0ef5 /gnu/packages
parent74ee98eed4e4962b4843630f9785d5c62c10f4bc (diff)
downloadguix-patches-9694b44e3b8aaac230c2ae8c8ddcf676ba19a1d7.tar
guix-patches-9694b44e3b8aaac230c2ae8c8ddcf676ba19a1d7.tar.gz
gnu: notmuch-addrlookup-c: Update to 9.
* gnu/packages/mail.scm (notmuch-addrlookup-c): Update to 9. [arguments]: Remove PREFIX from #:make-flags.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/mail.scm80
1 files changed, 36 insertions, 44 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 2ae3fda9a7..844e393a9e 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -919,51 +919,43 @@ ing, and tagging large collections of email messages.")
(license gpl3+)))
(define-public notmuch-addrlookup-c
- ;; This commit includes a compatibility fix for notmuch-0.25, and is not
- ;; currently part of any release. Please update this package when
- ;; notmuch-addrlookup-c-9 is released.
- (let ((commit "88f156d04990a71c6ad6fc2757b537b44e3c4d00")
- (revision "1")) ;Guix package revision
- (package
- (name "notmuch-addrlookup-c")
- (version (string-append "8-" revision "."
- (string-take commit 7)))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/aperezdc/notmuch-addrlookup-c.git")
- (commit commit)))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "0v0wzs7qzy4n1hbql8s10qrwgalcxdzbxf8pj6cii1pv2jwmkxbm"))))
- (build-system gnu-build-system)
- (arguments
- '(#:tests? #f ; no tests
- #:make-flags (list "CC=gcc"
- (string-append "PREFIX="
- (assoc-ref %outputs "out")))
- #:phases (modify-phases %standard-phases
- (delete 'configure)
- ;; Remove vim code completion config, it's not needed to
- ;; build (or be patched).
- (add-before 'patch-source-shebangs 'delete-ycm-file
- (lambda _ (delete-file ".ycm_extra_conf.py")))
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((bin (string-append
- (assoc-ref outputs "out") "/bin")))
- (install-file "notmuch-addrlookup" bin)))))))
- (native-inputs
- `(("pkg-config" ,pkg-config)))
- (inputs
- `(("glib" ,glib)
- ("notmuch" ,notmuch)))
- (home-page "https://github.com/aperezdc/notmuch-addrlookup-c")
- (synopsis "Address lookup tool for Notmuch")
- (description "This is an address lookup tool using a Notmuch database,
+ (package
+ (name "notmuch-addrlookup-c")
+ (version (string-append "9"))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/aperezdc/notmuch-addrlookup-c.git")
+ (commit (string-append "v" version))))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "1j3zdx161i1x4w0nic14ix5i8hd501rb31daf8api0k8855sx4rc"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ; no tests
+ #:make-flags (list "CC=gcc")
+ #:phases (modify-phases %standard-phases
+ (delete 'configure)
+ ;; Remove vim code completion config, it's not needed to
+ ;; build (or be patched).
+ (add-before 'patch-source-shebangs 'delete-ycm-file
+ (lambda _ (delete-file ".ycm_extra_conf.py")))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((bin (string-append
+ (assoc-ref outputs "out") "/bin")))
+ (install-file "notmuch-addrlookup" bin)))))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("glib" ,glib)
+ ("notmuch" ,notmuch)))
+ (home-page "https://github.com/aperezdc/notmuch-addrlookup-c")
+ (synopsis "Address lookup tool for Notmuch")
+ (description "This is an address lookup tool using a Notmuch database,
useful for email address completion.")
- (license license:expat))))
+ (license license:expat)))
(define-public python-notmuch
(package