summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-08-24 23:16:56 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-08-25 13:03:14 +0300
commit932edeb3a0f91571551c16e6fb7b75dd092d3902 (patch)
tree39854458fc99ed18f5de379f817a899495431811 /gnu/packages
parente5fca82414c6f21322e897dd41d26d0aced98dd6 (diff)
downloadguix-patches-932edeb3a0f91571551c16e6fb7b75dd092d3902.tar
guix-patches-932edeb3a0f91571551c16e6fb7b75dd092d3902.tar.gz
gnu: go-github-com-valyala-fasthttp: Skip tests with gccgo.
* gnu/packages/golang.scm (go-github-com-valyala-fasthttp)[arguments]: Don't run the test suite when building with gccgo.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 416208707e..383d4d1618 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9150,7 +9150,16 @@ anti-fragmentation protection.")
(base32 "12qwx0yk7wjj25v4fswgmj28r69gk94kqdmzavca8k9f0yznniz1"))))
(build-system go-build-system)
(arguments
- '(#:import-path "github.com/valyala/fasthttp"))
+ (list
+ #:import-path "github.com/valyala/fasthttp"
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs #:allow-other-keys #:rest args)
+ (unless
+ ;; Tests hang forever with gccgo.
+ (false-if-exception (search-input-file inputs "/bin/gccgo"))
+ (apply (assoc-ref %standard-phases 'check) args)))))))
(propagated-inputs
(list go-golang-org-x-sys
go-golang-org-x-net