summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2023-04-24 20:43:01 +0200
committerAndreas Enge <andreas@enge.fr>2023-04-24 20:43:01 +0200
commit92dd588b81e2b07eff8a083e998224963cfe2959 (patch)
tree1e437c7e0cbde691defe81c465ddf7d23d3313a1 /gnu/packages
parent09d2976c86f2cb1841ebe0685164912bfedfeeb5 (diff)
parentc7cdd4a6c7e795575c1baf6a655cb317f56fcf81 (diff)
downloadguix-patches-92dd588b81e2b07eff8a083e998224963cfe2959.tar
guix-patches-92dd588b81e2b07eff8a083e998224963cfe2959.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/audio.scm4
-rw-r--r--gnu/packages/dezyne.scm4
-rw-r--r--gnu/packages/emacs-xyz.scm41
-rw-r--r--gnu/packages/mail.scm13
-rw-r--r--gnu/packages/monitoring.scm4
-rw-r--r--gnu/packages/mpi.scm4
-rw-r--r--gnu/packages/security-token.scm4
-rw-r--r--gnu/packages/video.scm8
8 files changed, 43 insertions, 39 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 33bc074a13..dca5e516a1 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -5188,7 +5188,7 @@ bluetooth profile.")
(define-public libopenshot-audio
(package
(name "libopenshot-audio")
- (version "0.3.0")
+ (version "0.3.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -5197,7 +5197,7 @@ bluetooth profile.")
(file-name (git-file-name name version))
(sha256
(base32
- "1y3apyn71ysks88bv71knjvk832imnbpbb8mgib3q9b8pvdmjw3g"))))
+ "164ibsp5g162cyjgpa0ap35h75igmfnmhxmwkkk1fvm1cpbf1jgj"))))
(build-system cmake-build-system)
(inputs
(list alsa-lib
diff --git a/gnu/packages/dezyne.scm b/gnu/packages/dezyne.scm
index 6dd1c2426f..303c3f0436 100644
--- a/gnu/packages/dezyne.scm
+++ b/gnu/packages/dezyne.scm
@@ -31,14 +31,14 @@
(define-public dezyne
(package
(name "dezyne")
- (version "2.17.1")
+ (version "2.17.2")
(source
(origin
(method url-fetch)
(uri (string-append "https://dezyne.org/download/dezyne/"
name "-" version ".tar.gz"))
(sha256
- (base32 "008svf32sy80c98nax3xkvxb0b93xgh9xjvw5ygzkq8zflr3ihm8"))))
+ (base32 "1v0anwr0iic26ck796b29dfyj1dxkjf935g134z98s95hvzzrhm3"))))
(inputs (list bash-minimal
guile-3.0-latest
guile-json-4
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index cb8495f8e8..da81720312 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -25,7 +25,7 @@
;;; Copyright © 2017 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2017 George Clemmer <myglc2@gmail.com>
;;; Copyright © 2017, 2018 Feng Shu <tumashu@163.com>
-;;; Copyright © 2017, 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2017, 2020, 2023 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2017, 2018, 2019, 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2017 Mekeor Melire <mekeor.melire@gmail.com>
;;; Copyright © 2017 Peter Mikkelsen <petermikkelsen10@gmail.com>
@@ -5812,25 +5812,28 @@ saving won't move point back to the beginning of the buffer.")
(license license:gpl3+)))
(define-public emacs-git-timemachine
- (package
- (name "emacs-git-timemachine")
- (version "4.11")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://gitlab.com/pidu/git-timemachine.git")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1pz4l1xnq6s67w5yq9107vm8dg7rqf8n9dmbn90jys97c722g70n"))))
- (build-system emacs-build-system)
- (home-page "https://gitlab.com/pidu/git-timemachine")
- (synopsis "Step through historic versions of Git-controlled files")
- (description "This package enables you to step through historic versions
+ (let ((version "4.11")
+ (revision "0")
+ (commit "13769fb603ae88c64566529eae4525ce88026e86"))
+ (package
+ (name "emacs-git-timemachine")
+ (version (git-version version revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/pidu/git-timemachine.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0d1aj9xhcyksg115xl2yw0rd62hp53ig06y54jvii1l8vavb94jy"))))
+ (build-system emacs-build-system)
+ (home-page "https://gitlab.com/pidu/git-timemachine")
+ (synopsis "Step through historic versions of Git-controlled files")
+ (description "This package enables you to step through historic versions
of files under Git version control from within Emacs.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public emacs-minitest
(package
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 353773de09..f10c70db52 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -4077,20 +4077,20 @@ It is a replacement for the @command{urlview} program.")
(license license:gpl2+)))
(define-public mumi
- (let ((commit "b2a8280f158957e18d714dea78637f6504dd7613")
- (revision "1"))
+ (let ((commit "85d5efb4367b9178eb7093e3ebca760745de0753")
+ (revision "2"))
(package
(name "mumi")
(version (git-version "0.0.5" revision commit))
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://git.elephly.net/software/mumi.git")
+ (url "https://git.savannah.gnu.org/git/guix/mumi.git/")
(commit commit)))
(file-name (git-file-name name version))
(sha256
(base32
- "1ygcbrnwvqa4zi93mbry5afw6dr4fbm7pgkn1gbsydp6qjfsm88q"))))
+ "0yn8dfj3krqwfsdn888vbv903kfa7clmbj2xxin263zqcyzc3alq"))))
(build-system gnu-build-system)
(arguments
(list
@@ -4123,7 +4123,8 @@ It is a replacement for the @command{urlview} program.")
`("GUILE_LOAD_COMPILED_PATH" ":" prefix
(,go ,(getenv "GUILE_LOAD_COMPILED_PATH"))))))))))
(inputs
- (list guile-email
+ (list bash-minimal
+ guile-email
guile-fibers
guile-gcrypt
guile-json-4
@@ -4145,7 +4146,7 @@ It is a replacement for the @command{urlview} program.")
(sha256
(base32
"1gs1li48hqizx7lc4n2fdxn9i2v4vafkqpza7svvfpcamfz29jpi")))))
- (home-page "https://git.elephly.net/software/mumi.git")
+ (home-page "https://git.savannah.gnu.org/cgit/guix/mumi.git/")
(synopsis "Debbugs web interface")
(description "Mumi is a Debbugs web interface.")
(license license:agpl3+))))
diff --git a/gnu/packages/monitoring.scm b/gnu/packages/monitoring.scm
index 5ef40bdf58..d36ba707c7 100644
--- a/gnu/packages/monitoring.scm
+++ b/gnu/packages/monitoring.scm
@@ -681,7 +681,7 @@ the recorded data over time.")
(define-public fatrace
(package
(name "fatrace")
- (version "0.16.3")
+ (version "0.17.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -690,7 +690,7 @@ the recorded data over time.")
(file-name (git-file-name name version))
(sha256
(base32
- "1bxz6v1z0icp716jnv3knjyqp8bv6xnkz8gqd8z3g2b6yxj5xff3"))))
+ "067pj0z4np4mmhlin9411zpwwbfmn38ykvmxw35fnidf3kxcq49i"))))
(build-system gnu-build-system)
(arguments
`(#:phases
diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index f21bd16d3a..20fc1a16a4 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -184,7 +184,7 @@ bind processes, and much more.")
(define-public openmpi
(package
(name "openmpi")
- (version "4.1.4")
+ (version "4.1.5")
(source
(origin
(method url-fetch)
@@ -192,7 +192,7 @@ bind processes, and much more.")
(version-major+minor version)
"/downloads/openmpi-" version ".tar.bz2"))
(sha256
- (base32 "03ckngrff1cl0l81vfvrfhp99rbgk7s0633kr1l468yibwbjx4cj"))
+ (base32 "1qyvc77diyrxmviirdwqpibgm32c4vkdlvw8g79rsf2pq9mrhh56"))
(patches (search-patches "openmpi-mtl-priorities.patch"))))
(properties
diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index 2fae1676cc..253e67d0c5 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -126,7 +126,7 @@ readers and is needed to communicate with such devices through the
(define-public eid-mw
(package
(name "eid-mw")
- (version "5.1.8")
+ (version "5.1.10")
(source
(origin
(method git-fetch)
@@ -135,7 +135,7 @@ readers and is needed to communicate with such devices through the
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "11jf828ag8y5iykcfjmjc3n8g5mchpl3fxkr110civ3qqbdiw882"))))
+ (base32 "14nx0hdpv0w5wwsg3894g8pzxlzgp9ryd38k4djhcsyarvzfwynr"))))
(build-system glib-or-gtk-build-system)
(native-inputs
(list autoconf
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 1aae3e4985..838dfe7aab 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -4787,7 +4787,7 @@ create smoother and stable videos.")
(define-public libopenshot
(package
(name "libopenshot")
- (version "0.3.0")
+ (version "0.3.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -4796,7 +4796,7 @@ create smoother and stable videos.")
(file-name (git-file-name name version))
(sha256
(base32
- "0q2899hbaqwh1gxyl9x84l116g82glk0wmr3r1xvfwb107m3mvx9"))
+ "10s76x4hwm4ccxdy8cv1nks028hldjmx25yy42fnjc4vscy7yd8a"))
(modules '((guix build utils)))
(snippet '(begin
;; Allow overriding of the python installation dir
@@ -4851,7 +4851,7 @@ API. It includes bindings for Python, Ruby, and other languages.")
(define-public openshot
(package
(name "openshot")
- (version "3.0.0")
+ (version "3.1.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -4860,7 +4860,7 @@ API. It includes bindings for Python, Ruby, and other languages.")
(file-name (git-file-name name version))
(sha256
(base32
- "1az59whx9sga6m8m2c3ndfls5h07r0jn4jipnyxckpxl32vpd147"))
+ "1m1mq8kws00mwijx8j5gqharkw63jqyywbnzsswgcxlhmsyv3k4v"))
(modules '((guix build utils)))
(snippet
'(begin