summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSarah Morgensen <iskarian@mgsn.dev>2021-06-25 00:21:01 -0700
committerEfraim Flashner <efraim@flashner.co.il>2021-08-05 16:44:55 +0300
commit8cc36f76bbd96d6b6da96fee62515634d9da0803 (patch)
treee6bb9f2a88e547e3b7f526e98a9022542b08a617 /gnu/packages
parent457a472888d3e8171184755d53c318aa3fa99d0c (diff)
downloadguix-patches-8cc36f76bbd96d6b6da96fee62515634d9da0803.tar
guix-patches-8cc36f76bbd96d6b6da96fee62515634d9da0803.tar.gz
gnu: earlyoom: Patch tests for go-1.16.
* gnu/packages/linux.scm (earlyoom)[source]: Add snippet to not use modules in test suite. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/linux.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 4ca2a386e1..762cd03492 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3531,7 +3531,14 @@ from the module-init-tools project.")
(file-name (git-file-name name version))
(sha256
(base32
- "16iyn51xlrsbshc7p5xl2338yyfzknaqc538sa7mamgccqwgyvvq"))))
+ "16iyn51xlrsbshc7p5xl2338yyfzknaqc538sa7mamgccqwgyvvq"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (substitute* "Makefile"
+ (("go test -v")
+ "GO111MODULE=off go test -v"))
+ #t))))
(build-system gnu-build-system)
(arguments
`(#:phases