summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-02-06 18:46:34 +0100
committerLudovic Courtès <ludo@gnu.org>2016-02-06 21:46:25 +0100
commit8c4c2a983e28d08034cb151ed9c1a41094bc921b (patch)
treedc24303c50b6ec3ba9b81fc19fbf5448ead2083c /gnu/packages
parenta05d1d82c02a997038c43b4a0e97a8e3cc8cdb8b (diff)
downloadguix-patches-8c4c2a983e28d08034cb151ed9c1a41094bc921b.tar
guix-patches-8c4c2a983e28d08034cb151ed9c1a41094bc921b.tar.gz
gnu: Add Texinfo 6.1.
* gnu/packages/texinfo.scm (texinfo-6.1): New variable. * gnu/packages/emacs.scm (emacs): Add comment about 'info.info'.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs.scm3
-rw-r--r--gnu/packages/texinfo.scm14
2 files changed, 15 insertions, 2 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 68f4e0ab22..fc940eb487 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -89,7 +89,8 @@
"pwd"))))
(add-after 'install 'remove-info.info
(lambda* (#:key outputs #:allow-other-keys)
- ;; Remove 'info.info', which is provided by Texinfo.
+ ;; Remove 'info.info', which is provided by Texinfo <= 6.0.
+ ;; TODO: Remove this phase when we switch to Texinfo 6.1.
(let ((out (assoc-ref outputs "out")))
(delete-file
(string-append out "/share/info/info.info.gz"))
diff --git a/gnu/packages/texinfo.scm b/gnu/packages/texinfo.scm
index bffff788fc..5c1204ed2e 100644
--- a/gnu/packages/texinfo.scm
+++ b/gnu/packages/texinfo.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2016 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;;
@@ -62,6 +62,18 @@ their source and the command-line Info reader. The emphasis of the language
is on expressing the content semantically, avoiding physical markup commands.")
(license gpl3+)))
+(define-public texinfo-6.1
+ (package
+ (inherit texinfo)
+ (version "6.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/texinfo/texinfo-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "1ll3d0l8izygdxqz96wfr2631kxahifwdknpgsx2090vw963js5c"))))))
+
(define-public texinfo-5
(package (inherit texinfo)
(version "5.2")