summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-08-15 18:08:31 +0200
committerMarius Bakke <marius@gnu.org>2020-11-21 01:21:31 +0100
commit8b20f6c0433741f31bef9ff1dc908beb296d87e7 (patch)
treed3e9289660e25ca3669fdc79e19d6786da55ae8e /gnu/packages
parentabbb15309d7dd83bb99682e6962ff98f57f681f9 (diff)
downloadguix-patches-8b20f6c0433741f31bef9ff1dc908beb296d87e7.tar
guix-patches-8b20f6c0433741f31bef9ff1dc908beb296d87e7.tar.gz
gnu: Add python-gorilla.
* gnu/packages/python-xyz.scm (python-gorilla): New public variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 52b45e9bb4..b55c882d07 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8635,6 +8635,26 @@ should be stored on various operating systems.")
(define-public python2-appdirs
(package-with-python2 python-appdirs))
+(define-public python-gorilla
+ (package
+ (name "python-gorilla")
+ (version "0.3.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "gorilla" version))
+ (sha256
+ (base32
+ "0b40blcp6fih4nvqbilra4qw1dfccv1ahjmr41ac4d9rjadqkcpy"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/christophercrouzet/gorilla")
+ (synopsis "Convenient monkey patching with Python")
+ (description
+ "Gorilla is a Python library that provides a convenient approach to
+monkey patching. Monkey patching is the process of modifying module and
+class attributes at runtime with the purpose of replacing or extending
+third-party code.")
+ (license license:expat)))
+
(define-public python-llfuse
(package
(name "python-llfuse")