summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-08-14 13:24:11 +0000
committerEfraim Flashner <efraim@flashner.co.il>2016-09-05 21:18:02 +0300
commit8a0773a2b4e4f3d7f3536a0c5746e2258cbc9a09 (patch)
tree22d8e07951006962c30359b25346b6d1735d8052 /gnu/packages
parent951e924c9b0f34ed57d7676b2f67d520b05b8482 (diff)
downloadguix-patches-8a0773a2b4e4f3d7f3536a0c5746e2258cbc9a09.tar
guix-patches-8a0773a2b4e4f3d7f3536a0c5746e2258cbc9a09.tar.gz
gnu: Add perl-datetime-format-w3cdtf.
* gnu/packages/perl.scm (perl-datetime-format-w3cdtf): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/perl.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index db941fbf09..78c4a9a5db 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -1813,6 +1813,32 @@ edges (mainly concerning timezone detection and selection).")
This module parses and emits such dates.")
(license (package-license perl))))
+(define-public perl-datetime-format-w3cdtf
+ (package
+ (name "perl-datetime-format-w3cdtf")
+ (version "0.06")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/G/GW/GWILLIAMS/"
+ "DateTime-Format-W3CDTF-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0ymxizwd2zfx8b4bmrmv4k439qwfwf2522jrvn4hlay5v6z459dr"))))
+ (build-system perl-build-system)
+ (inputs
+ `(("perl-datetime" ,perl-datetime)))
+ (native-inputs
+ `(("perl-test-pod" ,perl-test-pod)
+ ("perl-test-pod-coverage" ,perl-test-pod-coverage)))
+ (home-page "http://search.cpan.org/dist/DateTime-Format-W3CDTF")
+ (synopsis "Parse and format W3CDTF datetime strings")
+ (description
+ "This module understands the W3CDTF date/time format, an ISO 8601 profile,
+defined at https://www.w3.org/TR/NOTE-datetime. This format is the native date
+format of RSS 1.0. It can be used to parse these formats in order to create
+the appropriate objects.")
+ (license (package-license perl))))
+
(define-public perl-devel-caller
(package
(name "perl-devel-caller")