summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-01-09 12:26:50 +0100
committerMarius Bakke <marius@gnu.org>2022-01-09 14:49:15 +0100
commit8993d9663606eeb075725daa669482d428d2356d (patch)
treea7acb3f98921f8ad1bf846099c7a6a429211b220 /gnu/packages
parent796bb42c11b9e8b06933ed6e331b5277bec2cbac (diff)
downloadguix-patches-8993d9663606eeb075725daa669482d428d2356d.tar
guix-patches-8993d9663606eeb075725daa669482d428d2356d.tar.gz
gnu: zig: Build with LLD 12.
This fixes a regression introduced in a05e573d60bf64129abf4d4e5f27355c84ebb2ee as the LLD version must match the LLVM version. * gnu/packages/llvm.scm (lld-12): New variable. * gnu/packages/zig.scm (zig)[inputs]: Change from LLD to LLD-12.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/llvm.scm13
-rw-r--r--gnu/packages/zig.scm2
2 files changed, 14 insertions, 1 deletions
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index c7d071e155..e708c02884 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -1139,6 +1139,19 @@ of programming tools as well as libraries with equivalent functionality.")
components which highly leverage existing libraries in the larger LLVM Project.")
(license license:asl2.0))) ; With LLVM exception
+(define-public lld-12
+ (package
+ (inherit lld)
+ (version "12.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (llvm-uri "lld" version))
+ (sha256
+ (base32
+ "0qg3fgc7wj34hdkqn21y03zcmsdd01szhhm1hfki63iifrm3y2v9"))))
+ (inputs (modify-inputs (package-inputs lld)
+ (replace "llvm" llvm-12)))))
+
(define* (make-lld-wrapper lld #:key lld-as-ld?)
"Return a LLD wrapper. When LLD-AS-LD? is true, create a 'ld' symlink that
points to 'lld'."
diff --git a/gnu/packages/zig.scm b/gnu/packages/zig.scm
index ea0ec89b0b..9cd869389b 100644
--- a/gnu/packages/zig.scm
+++ b/gnu/packages/zig.scm
@@ -45,7 +45,7 @@
(build-system cmake-build-system)
(inputs
(list clang-12 ; Clang propagates llvm.
- lld))
+ lld-12))
;; Zig compiles fine with GCC, but also needs native LLVM libraries.
(native-inputs
(list llvm-12))