summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2020-09-21 00:06:07 +0530
committerArun Isaac <arunisaac@systemreboot.net>2020-10-12 11:42:04 +0530
commit7f4b985f063601690dcc6d4af4874f8aeab60af5 (patch)
treed5554c7ee5935fe73518ef892aef8b7a8e408204 /gnu/packages
parent32cd33bf76c88d1f7fda9fead6b088e61de5114c (diff)
downloadguix-patches-7f4b985f063601690dcc6d4af4874f8aeab60af5.tar
guix-patches-7f4b985f063601690dcc6d4af4874f8aeab60af5.tar.gz
gnu: Add rust-scheduled-thread-pool-0.2.
* gnu/packages/crates-io.scm (rust-scheduled-thread-pool-0.2): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-io.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index f769e38480..b167cbb993 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -22779,6 +22779,27 @@ paths point to the same file.")
server functionality.")
(license license:expat)))
+(define-public rust-scheduled-thread-pool-0.2
+ (package
+ (name "rust-scheduled-thread-pool")
+ (version "0.2.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "scheduled-thread-pool" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1mz7s21q1d7xn9j15dlhhv1y86q2r2z6hpax5nh3y1q42byp8vyw"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-parking-lot" ,rust-parking-lot-0.11))))
+ (home-page "https://github.com/sfackler/scheduled-thread-pool")
+ (synopsis "A scheduled thread pool")
+ (description "This package provides a scheduled thread pool.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-scoped-threadpool-0.1
(package
(name "rust-scoped-threadpool")