summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2017-04-18 19:42:19 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2017-05-01 01:14:27 +0200
commit7cf06d62bfd0c8a97d33c7ff8e8ba9c9322b2b7a (patch)
tree087528ea64c69fd0fd799962cad2aafb43b76453 /gnu/packages
parentb3542d77febda2d0dd56a3e847a939f22e338d5c (diff)
downloadguix-patches-7cf06d62bfd0c8a97d33c7ff8e8ba9c9322b2b7a.tar
guix-patches-7cf06d62bfd0c8a97d33c7ff8e8ba9c9322b2b7a.tar.gz
gnu: Add gcc-vc4.
Fixes <https://bugs.gnu.org/26541>. * gnu/packages/bootstrap.scm (glibc-dynamic-linker): Add vc4-elf. * gnu/packages/embedded.scm (gcc-vc4): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bootstrap.scm1
-rw-r--r--gnu/packages/embedded.scm24
2 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/bootstrap.scm b/gnu/packages/bootstrap.scm
index 048fe26f1a..f43decc96e 100644
--- a/gnu/packages/bootstrap.scm
+++ b/gnu/packages/bootstrap.scm
@@ -179,6 +179,7 @@ successful, or false to signal an error."
((string=? system "avr") "no-ld.so")
((string=? system "propeller-elf") "no-ld.so")
((string=? system "i686-mingw") "no-ld.so")
+ ((string=? system "vc4-elf") "no-ld.so")
(else (error "dynamic linker name not known for this system"
system))))
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index 36f872cdf2..b919bdf6c4 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -773,3 +773,27 @@ simulator.")
the Raspberry Pi chip.")
(license license:gpl3+)
(home-page "https://github.com/puppeh/vc4-toolchain/"))))
+
+(define-public gcc-vc4
+ (let ((commit "165f6d0e11d2e76ee799533bb45bd5c92bf60dc2")
+ (xgcc (cross-gcc "vc4-elf" binutils-vc4)))
+ (package (inherit xgcc)
+ (name "gcc-vc4")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/puppeh/gcc-vc4.git")
+ (commit commit)))
+ (file-name (string-append name
+ "-"
+ (package-version xgcc)
+ "-checkout"))
+ (sha256
+ (base32
+ "13h30qjcwnlz6lfma1d82nnvfmjnhh7abkagip4vly6vm5fpnvf2"))))
+ (native-inputs
+ `(("flex" ,flex)
+ ,@(package-native-inputs xgcc)))
+ (synopsis "GCC for VC4")
+ (description "This package provides @code{gcc} for VideoCore IV,
+the Raspberry Pi chip."))))