summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2021-05-07 11:54:49 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2021-05-07 11:54:49 +0200
commit7ae9ef3b54e5577275cdae9b603f8e5a0141a159 (patch)
tree2d4674618ae3aee5f11fa799dd45f40fff59952e /gnu/packages
parentff8f743f7c93496e15702237eaa3c15ce5536c48 (diff)
downloadguix-patches-7ae9ef3b54e5577275cdae9b603f8e5a0141a159.tar
guix-patches-7ae9ef3b54e5577275cdae9b603f8e5a0141a159.tar.gz
Revert "gnu: Add pathname-utils."
This reverts commit 22796f1ad16abb7b1519d11332175d147ae10b82. This is an accidental duplicate of 3de01371dc0c5fb0847d8ad64bc508f77396f56b.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/lisp-xyz.scm32
1 files changed, 0 insertions, 32 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index a00c272a43..cf6315ae90 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -16368,35 +16368,3 @@ for Common Lisp.")
(define-public cl-bknr-datastore
(sbcl-package->cl-source-package sbcl-bknr-datastore))
-
-(define-public sbcl-pathname-utils
- ;; No new release in years.
- (let ((commit "4ebc0fe97b7e299ba93cc9c50938445eef77e352"))
- (package
- (name "sbcl-pathname-utils")
- (version (git-version "1.1.0" "1" commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/Shinmera/pathname-utils")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0zjv39lrqdq96m4cypig33fh3iw5l7ivm3lwvzh08h70jswda0y4"))))
- (build-system asdf-build-system/sbcl)
- (native-inputs
- `(("parachute" ,sbcl-parachute)))
- (home-page "https://github.com/privet-kitty/dufy")
- (synopsis "Pathname manipulation library for Common Lisp")
- (description
- "This is a Common Lisp collection of common tests and operations to
-help handling pathnames. It does not actually deal in handling the accessing
-of files on the underlying system however.")
- (license license:zlib))))
-
-(define-public ecl-pathname-utils
- (sbcl-package->ecl-package sbcl-pathname-utils))
-
-(define-public cl-pathname-utils
- (sbcl-package->cl-source-package sbcl-pathname-utils))