summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-08-08 13:46:17 -0400
committerMark H Weaver <mhw@netris.org>2015-08-08 14:09:56 -0400
commit7a75b02ae54b054cdc614d1cb5af7ed26c4f63c3 (patch)
tree77a1b6f6e073a293e85775d6a667a3b1dbede3dd /gnu/packages
parent831bc1468ea27732ba59d58e4b38a192151aa123 (diff)
downloadguix-patches-7a75b02ae54b054cdc614d1cb5af7ed26c4f63c3.tar
guix-patches-7a75b02ae54b054cdc614d1cb5af7ed26c4f63c3.tar.gz
gnu: Move ghostscript-with-x into (gnu packages ghostscript).
* gnu/packages/gv.scm (ghostscript/x): Move ... * gnu/packages/ghostscript.scm (ghostscript/x): ... to here.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ghostscript.scm10
-rw-r--r--gnu/packages/gv.scm7
2 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/ghostscript.scm b/gnu/packages/ghostscript.scm
index bd57889888..818072ac5e 100644
--- a/gnu/packages/ghostscript.scm
+++ b/gnu/packages/ghostscript.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2015 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -29,6 +29,7 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages tcl)
+ #:use-module (gnu packages xorg)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
@@ -183,6 +184,13 @@ output file formats and printers.")
(license license:agpl3+)
(home-page "http://www.gnu.org/software/ghostscript/")))
+(define-public ghostscript/x
+ (package (inherit ghostscript)
+ (name (string-append (package-name ghostscript) "-with-x"))
+ (inputs `(("libxext" ,libxext)
+ ("libxt" ,libxt)
+ ,@(package-inputs ghostscript)))))
+
(define-public ijs
(package
(name "ijs")
diff --git a/gnu/packages/gv.scm b/gnu/packages/gv.scm
index f635942119..5f8532144b 100644
--- a/gnu/packages/gv.scm
+++ b/gnu/packages/gv.scm
@@ -28,13 +28,6 @@
#:use-module (guix download)
#:use-module (guix build-system gnu))
-(define-public ghostscript/x
- (package (inherit ghostscript)
- (name (string-append (package-name ghostscript) "-with-x"))
- (inputs `(("libxext" ,libxext)
- ("libxt" ,libxt)
- ,@(package-inputs ghostscript)))))
-
(define-public gv
(package
(name "gv")