summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTanguy Le Carrour <tanguy@bioneland.org>2020-07-28 11:28:16 +0200
committerOleg Pykhalov <go.wigust@gmail.com>2020-07-30 20:47:38 +0300
commit74e9c31a1080f9d40efdcda4cbb450b88e4d1cfd (patch)
tree1c1fadd1a98c3c409c251272e3e02d500cf8368f /gnu/packages
parenta127e52f601ee73f675d5d28eac2388bb1ad11b0 (diff)
downloadguix-patches-74e9c31a1080f9d40efdcda4cbb450b88e4d1cfd.tar
guix-patches-74e9c31a1080f9d40efdcda4cbb450b88e4d1cfd.tar.gz
gnu: Add python-crashtest.
* gnu/packages/python-xyz.scm (python-crashtest): New public variable. Signed-off-by: Oleg Pykhalov <go.wigust@gmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a5c2e60ce4..d4d507b697 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8173,6 +8173,24 @@ output.")
(define-public python2-cram
(package-with-python2 python-cram))
+(define-public python-crashtest
+ (package
+ (name "python-crashtest")
+ (version "0.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "crashtest" version))
+ (sha256
+ (base32
+ "056zzbznl3xfnbblfci8lvcam3h7k7va68vi6asrm4q0ck4nrh79"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/sdispater/crashtest")
+ (synopsis "Manage Python errors with ease")
+ (description
+ "Python library that makes exceptions handling and inspection easier.")
+ (license license:expat)))
+
(define-public python-straight-plugin
(package
(name "python-straight-plugin")