summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-07-16 18:20:30 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-07-16 20:12:06 +0200
commit702a10125724c2af7eadfab3a9edf71c3d32936b (patch)
tree410d7aed53005feddd57c597c4604ddf66f50e8d /gnu/packages
parent228d29010679b3090cf359fd3d21d7f5bc33b008 (diff)
downloadguix-patches-702a10125724c2af7eadfab3a9edf71c3d32936b.tar
guix-patches-702a10125724c2af7eadfab3a9edf71c3d32936b.tar.gz
gnu: Use HTTPS for github.com (and subdomains) home pages.
* gnu/packages/bioconductor.scm (r-qvalue)[home-page]: Use HTTPS and follow permanent redirection. * gnu/packages/check.scm (python-codecov, python-nosexcover) [home-page]: Likewise. * gnu/packages/cran.scm (r-ffbase, r-ggrepel, r-valr) [home-page]: Likewise. * gnu/packages/crates-io.scm (rust-block-0.1, rust-dispatch-0.1) (rust-objc-0.2, rust-objc-exception-0.1) (rust-objc-foundation-0.1, rust-objc-id-0.1, rust-objc-test-utils-0.0) (rust-onig-5.0, rust-onig-sys-69.2, rust-vergen-3.1) [home-page]: Likewise. * gnu/packages/finance.scm (ledger-agent, keepkey-agent) [home-page]: Likewise. * gnu/packages/haskell-check.scm (ghc-tasty-expected-failure) [home-page]: Likewise. * gnu/packages/haskell-web.scm (ghc-bsb-http-chunked, ghc-warp) (ghc-warp-tls)[home-page]: Likewise. * gnu/packages/haskell-xyz.scm (ghc-configurator, ghc-hasktags) (ghc-linear, ghc-newtype-generics, ghc-retry, ghc-xdg-basedir) (ghc-pretty-show)[home-page]: Likewise. * gnu/packages/java.scm (java-javax-inject)[home-page]: Likewise. * gnu/packages/libffi.scm (ruby-ffi)[home-page]: Likewise. * gnu/packages/linux.scm (procenv)[home-page]: Likewise. * gnu/packages/python-web.scm (python-aiodns, python-flask-htpasswd) (python-pycares)[home-page]: Likewise. * gnu/packages/python-xyz.scm (python-progressbar33, python-whatever) (python-funcy)[home-page]: Likewise. * gnu/packages/ruby.scm (ruby-rubyzip, ruby-spinach, ruby-gherkin-ruby) (ruby-code-statistics, ruby-colorize, ruby-wwtd)[home-page]: Likewise.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioconductor.scm2
-rw-r--r--gnu/packages/check.scm4
-rw-r--r--gnu/packages/cran.scm6
-rw-r--r--gnu/packages/crates-io.scm20
-rw-r--r--gnu/packages/finance.scm4
-rw-r--r--gnu/packages/haskell-check.scm2
-rw-r--r--gnu/packages/haskell-web.scm6
-rw-r--r--gnu/packages/haskell-xyz.scm14
-rw-r--r--gnu/packages/java.scm2
-rw-r--r--gnu/packages/libffi.scm2
-rw-r--r--gnu/packages/linux.scm2
-rw-r--r--gnu/packages/python-web.scm6
-rw-r--r--gnu/packages/python-xyz.scm6
-rw-r--r--gnu/packages/ruby.scm12
14 files changed, 44 insertions, 44 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 3ab94cb431..b191c8b4ae 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1587,7 +1587,7 @@ Affymetrix (CEL files) and NimbleGen arrays (XYS files).")
("r-reshape2" ,r-reshape2)))
(native-inputs
`(("r-knitr" ,r-knitr)))
- (home-page "http://github.com/jdstorey/qvalue")
+ (home-page "https://github.com/StoreyLab/qvalue")
(synopsis "Q-value estimation for false discovery rate control")
(description
"This package takes a list of p-values resulting from the simultaneous
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 8dd4b364ef..661ed65e53 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1600,7 +1600,7 @@ testing frameworks.")
(propagated-inputs
`(("python-coverage" ,python-coverage)
("python-requests" ,python-requests)))
- (home-page "http://github.com/codecov/codecov-python")
+ (home-page "https://github.com/codecov/codecov-python")
(synopsis "Upload code coverage reports to @code{codecov.io}")
(description
"Codecov collects code coverage reports from code written in Python, Java,
@@ -2163,7 +2163,7 @@ a fork of pytest-capturelog.")
(propagated-inputs
`(("python-coverage" ,python-coverage)
("python-nose" ,python-nose)))
- (home-page "http://github.com/cmheisel/nose-xcover")
+ (home-page "https://github.com/cmheisel/nose-xcover")
(synopsis "Extends nose.plugins.cover to add Cobertura-style XML reports")
(description "Nose-xcover is a companion to the built-in
@code{nose.plugins.cover}. This plugin will write out an XML coverage report
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index d87b5d5b06..e6fd3f27c3 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -2347,7 +2347,7 @@ in main memory.")
`(("r-bit" ,r-bit)
("r-fastmatch" ,r-fastmatch)
("r-ff" ,r-ff)))
- (home-page "http://github.com/edwindj/ffbase")
+ (home-page "https://github.com/edwindj/ffbase")
(synopsis "Basic statistical functions for package 'ff'")
(description
"This package extends the out of memory vectors of @code{ff} with
@@ -3530,7 +3530,7 @@ for certain use cases.")
("r-scales" ,r-scales)))
(native-inputs
`(("r-knitr" ,r-knitr))) ; for vignettes
- (home-page "http://github.com/slowkow/ggrepel")
+ (home-page "https://github.com/slowkow/ggrepel")
(synopsis "Repulsive text and label geometries for ggplot2")
(description
"This package provides text and label geometries for ggplot2 that help to
@@ -13205,7 +13205,7 @@ plotting functions are available for analyzing clustering results.")
("r-tibble" ,r-tibble)))
(native-inputs
`(("r-knitr" ,r-knitr)))
- (home-page "http://github.com/rnabioco/valr")
+ (home-page "https://github.com/rnabioco/valr")
(synopsis "Genome interval arithmetic in R")
(description
"This package enables you to read and manipulate genome intervals and
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 806e111f6f..9df41311a1 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -1995,7 +1995,7 @@ BLAKE2bp hash functions.")
`(#:skip-build? #t
#:cargo-development-inputs
(("rust-objc-test-utils" ,rust-objc-test-utils-0.0))))
- (home-page "http://github.com/SSheldon/rust-block")
+ (home-page "https://github.com/SSheldon/rust-block")
(synopsis "Rust interface for Apple's C language extension of blocks")
(description "This package provides a rust interface for Apple's C language
extension of blocks.")
@@ -5724,7 +5724,7 @@ for intentionally leaking memory")
"019nzy993hxaiazcdnayx3csv2iki34i535asw11ki96hakkrs84"))))
(build-system cargo-build-system)
(arguments '(#:tests? #f)) ; Tests only run on Mac.
- (home-page "http://github.com/SSheldon/rust-dispatch")
+ (home-page "https://github.com/SSheldon/rust-dispatch")
(synopsis "Rust wrapper for Apple's Grand Central Dispatch")
(description "This package provides a Rust wrapper for Apple's Grand
Central Dispatch.")
@@ -15258,7 +15258,7 @@ giga, kibi.")
#:cargo-inputs
(("rust-malloc-buf" ,rust-malloc-buf-0.0)
("rust-objc-exception" ,rust-objc-exception-0.1))))
- (home-page "http://github.com/SSheldon/rust-objc")
+ (home-page "https://github.com/SSheldon/rust-objc")
(synopsis "Objective-C Runtime bindings and wrapper for Rust")
(description "This package provides an Objective-C Runtime bindings and
wrapper for Rust.")
@@ -15282,7 +15282,7 @@ wrapper for Rust.")
`(#:skip-build? #t
#:cargo-inputs
(("rust-cc" ,rust-cc-1.0))))
- (home-page "http://github.com/SSheldon/rust-objc-exception")
+ (home-page "https://github.com/SSheldon/rust-objc-exception")
(synopsis "Rust interface for Objective-C's throw and try/catch statements")
(description
"This package provides a Rust interface for Objective-C's throw and
@@ -15309,7 +15309,7 @@ try/catch statements.")
(("rust-block" ,rust-block-0.1)
("rust-objc" ,rust-objc-0.2)
("rust-objc-id" ,rust-objc-id-0.1))))
- (home-page "http://github.com/SSheldon/rust-objc-foundation")
+ (home-page "https://github.com/SSheldon/rust-objc-foundation")
(synopsis "Rust wrapper for Objective-C's Foundation framework")
(description "This package provides a rust wrapper for Objective-C's
Foundation framework.")
@@ -15332,7 +15332,7 @@ Foundation framework.")
(arguments
`(#:tests? #f ; Tests require gcc-objc.
#:cargo-inputs (("rust-objc" ,rust-objc-0.2))))
- (home-page "http://github.com/SSheldon/rust-objc-id")
+ (home-page "https://github.com/SSheldon/rust-objc-id")
(synopsis "Rust smart pointers for Objective-C reference counting")
(description
"This package provides Rust smart pointers for Objective-C reference counting.")
@@ -15356,7 +15356,7 @@ Foundation framework.")
`(#:skip-build? #t
#:cargo-inputs
(("rust-gcc" ,rust-gcc-0.3))))
- (home-page "http://github.com/SSheldon/rust-objc")
+ (home-page "https://github.com/SSheldon/rust-objc")
(synopsis "Utilities for testing Objective-C interop")
(description
"This package provides utilities for testing Objective-C interop.")
@@ -15478,7 +15478,7 @@ Things in odds may move to more appropriate crates if we find them.")
("rust-bitflags" ,rust-bitflags-1)
("rust-lazy-static" ,rust-lazy-static-1)
("rust-onig-sys" ,rust-onig-sys-69.2))))
- (home-page "http://github.com/iwillspeak/rust-onig")
+ (home-page "https://github.com/rust-onig/rust-onig")
(synopsis
"Rust bindings for the Oniguruma regular expression library")
(description
@@ -15507,7 +15507,7 @@ character encodings and regex syntaxes.")
(("rust-pkg-config" ,rust-pkg-config-0.3)
("rust-bindgen" ,rust-bindgen-0.50)
("rust-cc" ,rust-cc-1.0))))
- (home-page "http://github.com/iwillspeak/rust-onig")
+ (home-page "https://github.com/rust-onig/rust-onig")
(synopsis
"Rust bindings to the oniguruma library.")
(description
@@ -28139,7 +28139,7 @@ designed for reexporting.")
(("rust-chrono" ,rust-chrono-0.4)
("rust-chrono" ,rust-chrono-0.4)
("rust-bitflags" ,rust-bitflags-1))))
- (home-page "http://github.com/rustyhorde/vergen")
+ (home-page "https://github.com/rustyhorde/vergen")
(synopsis "Generate version related functions")
(description
"Generate version related functions.")
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index d403bc2510..1cd9014e45 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -965,7 +965,7 @@ the KeepKey Hardware Wallet.")
(inputs
`(("python-ledgerblue" ,python-ledgerblue)
("python-trezor-agent" ,python-trezor-agent)))
- (home-page "http://github.com/romanz/trezor-agent")
+ (home-page "https://github.com/romanz/trezor-agent")
(synopsis "Ledger as hardware SSH/GPG agent")
(description "This package allows using Ledger as hardware SSH/GPG agent.
@@ -1024,7 +1024,7 @@ agent.")
(inputs
`(("python-keepkey" ,python-keepkey)
("python-trezor-agent" ,python-trezor-agent)))
- (home-page "http://github.com/romanz/trezor-agent")
+ (home-page "https://github.com/romanz/trezor-agent")
(synopsis "KeepKey as hardware SSH/GPG agent")
(description "This package allows using KeepKey as a hardware SSH/GPG
agent.")
diff --git a/gnu/packages/haskell-check.scm b/gnu/packages/haskell-check.scm
index bb7f57b49d..c2cffbad9e 100644
--- a/gnu/packages/haskell-check.scm
+++ b/gnu/packages/haskell-check.scm
@@ -392,7 +392,7 @@ been added since previous test run.")
(inputs
`(("ghc-tagged" ,ghc-tagged)
("ghc-tasty" ,ghc-tasty)))
- (home-page "http://github.com/nomeata/tasty-expected-failure")
+ (home-page "https://github.com/nomeata/tasty-expected-failure")
(synopsis "Mark tasty tests as failure expected")
(description
"With the function @code{Test.Tasty.ExpectedFailure.expectFail} in the
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index 85c9aa9755..812af1fbc2 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -568,7 +568,7 @@ Haskell's Web Application Interface (WAI).")
("ghc-tasty-hedgehog" ,ghc-tasty-hedgehog)
("ghc-tasty-hunit" ,ghc-tasty-hunit)
("ghc-doctest" ,ghc-doctest)))
- (home-page "http://github.com/sjakobi/bsb-http-chunked")
+ (home-page "https://github.com/sjakobi/bsb-http-chunked")
(synopsis "Chunked HTTP transfer encoding for bytestring builders")
(description "This Haskell library contains functions for encoding
bytestring builders for chunked Hypertext Transfer Protocol (HTTP) 1.1
@@ -616,7 +616,7 @@ transfers.")
("ghc-hunit" ,ghc-hunit)
("ghc-http-client" ,ghc-http-client)
("hspec-discover" ,hspec-discover)))
- (home-page "http://github.com/yesodweb/wai")
+ (home-page "https://github.com/yesodweb/wai")
(synopsis "HTTP server library for Haskell's WAI")
(description "Warp is a server library for HTTP/1.x and HTTP/2
based WAI (Web Application Interface in Haskell).")
@@ -671,7 +671,7 @@ limitation, automatic pruning, energy saving and replay resistance.")
("ghc-tls-session-manager" ,ghc-tls-session-manager)
("ghc-wai" ,ghc-wai)
("ghc-warp" ,ghc-warp)))
- (home-page "http://github.com/yesodweb/wai")
+ (home-page "https://github.com/yesodweb/wai")
(synopsis "SSL/TLS support for Warp")
(description "This package provides SSL/TLS support for Warp,
a WAI handler, via the native Haskell TLS implementation.")
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 234f75dbfc..a5ceef1f54 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -2472,7 +2472,7 @@ interface}.")
`(("ghc-hunit" ,ghc-hunit)
("ghc-test-framework" ,ghc-test-framework)
("ghc-test-framework-hunit" ,ghc-test-framework-hunit)))
- (home-page "http://github.com/bos/configurator")
+ (home-page "https://github.com/bos/configurator")
(synopsis "Configuration management")
(description
"This package provides a configuration management library for programs
@@ -5492,7 +5492,7 @@ template-haskell abstract syntax.")
("ghc-utf8-string" ,ghc-utf8-string)
("ghc-microlens-platform" ,ghc-microlens-platform)
("ghc-hunit" ,ghc-hunit)))
- (home-page "http://github.com/MarcWeber/hasktags")
+ (home-page "https://github.com/MarcWeber/hasktags")
(synopsis "Make @code{Ctags} and @code{Etags} files for Haskell programs")
(description
"This package provides a means of generating tag files for Emacs and
@@ -6991,7 +6991,7 @@ Kaseorg.")
("ghc-test-framework" ,ghc-test-framework)
("ghc-test-framework-hunit" ,ghc-test-framework-hunit)
("ghc-hunit" ,ghc-hunit)))
- (home-page "http://github.com/ekmett/linear/")
+ (home-page "https://github.com/ekmett/linear/")
(synopsis "Linear algebra library for Haskell")
(description
"This package provides types and combinators for linear algebra on free
@@ -8258,7 +8258,7 @@ IPv4, IPv6 and MAC addresses.")
(native-inputs
`(("ghc-hspec" ,ghc-hspec)
("hspec-discover" ,hspec-discover)))
- (home-page "http://github.com/sjakobi/newtype-generics")
+ (home-page "https://github.com/sjakobi/newtype-generics")
(synopsis "Typeclass and set of functions for working with newtypes")
(description "The @code{Newtype} typeclass represents the packing and
unpacking of a newtype, and allows you to operate under that newtype with
@@ -9622,7 +9622,7 @@ ByteStrings in the style of other common *nix hex dump tools.")
(inputs
`(("ghc-haskell-lexer" ,ghc-haskell-lexer)
("ghc-happy" ,ghc-happy)))
- (home-page "http://wiki.github.com/yav/pretty-show")
+ (home-page "https://wiki.github.com/yav/pretty-show")
(synopsis "Tools for working with derived `Show` instances")
(description
"This package provides a library and an executable for working with
@@ -10565,7 +10565,7 @@ code where you can safely allocate resources.")
("ghc-tasty-hunit" ,ghc-tasty-hunit)
("ghc-tasty-hedgehog" ,ghc-tasty-hedgehog)
("ghc-hedgehog" ,ghc-hedgehog)))
- (home-page "http://github.com/Soostone/retry")
+ (home-page "https://github.com/Soostone/retry")
(synopsis "Retry combinators for monadic actions that may fail")
(description "This package exposes combinators that can wrap
arbitrary monadic actions. They run the action and potentially retry
@@ -14351,7 +14351,7 @@ parts.")
(base32
"0azlzaxp2dn4l1nr7shsxah2magk1szf6fx0mv75az00qsjw6qg4"))))
(build-system haskell-build-system)
- (home-page "http://github.com/willdonnelly/xdg-basedir")
+ (home-page "https://github.com/willdonnelly/xdg-basedir")
(synopsis "XDG Base Directory library for Haskell")
(description "This package provides a library implementing the XDG Base Directory spec.")
(license license:bsd-3)))
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 289bdd74d4..92df503b09 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -9079,7 +9079,7 @@ software engineering people who are interested in Aspect-Oriented Programming
`(#:jar-name "java-javax-inject.jar"
#:jdk ,icedtea-8
#:tests? #f)); no tests
- (home-page "http://github.com/javax-inject/javax-inject")
+ (home-page "https://github.com/javax-inject/javax-inject")
(synopsis "JSR-330: Dependency Injection for Java")
(description "This package specifies a means for obtaining objects in such
a way as to maximize reusability, testability and maintainability compared to
diff --git a/gnu/packages/libffi.scm b/gnu/packages/libffi.scm
index 36f6e5ece6..ec8703ffdb 100644
--- a/gnu/packages/libffi.scm
+++ b/gnu/packages/libffi.scm
@@ -248,5 +248,5 @@ project.")
dynamic libraries, binding functions within them, and calling those functions
from Ruby code. Moreover, a Ruby-FFI extension works without changes on Ruby
and JRuby.")
- (home-page "http://wiki.github.com/ffi/ffi")
+ (home-page "https://wiki.github.com/ffi/ffi")
(license bsd-3)))
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 80f546e056..1b71bc1e0c 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -6430,7 +6430,7 @@ the MTP device as a file system.")
itself and its environment as possible. It can be used as a test
tool, to understand the type of environment a process runs in, and for
comparing system environments.")
- (home-page "http://github.com/jamesodhunt/procenv/")
+ (home-page "https://github.com/jamesodhunt/procenv/")
(license license:gpl3+)))
(define-public libfabric
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 1d7cfd852d..0624cc967a 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -187,7 +187,7 @@ aiohttp. It supports SOCKS4(a) and SOCKS5.")
`(("python-pycares" ,python-pycares)))
(arguments
`(#:tests? #f)) ;tests require internet access
- (home-page "http://github.com/saghul/aiodns")
+ (home-page "https://github.com/saghul/aiodns")
(synopsis "Simple DNS resolver for asyncio")
(description "@code{aiodns} provides a simple way for doing
asynchronous DNS resolutions with a synchronous looking interface by
@@ -2368,7 +2368,7 @@ pretty printer and a tree visitor.")
("python-itsdangerous" ,python-itsdangerous)
("python-passlib" ,python-passlib)
("python-tox" ,python-tox)))
- (home-page "http://github.com/carsongee/flask-htpasswd")
+ (home-page "https://github.com/carsongee/flask-htpasswd")
(synopsis "Basic authentication via htpasswd files in Flask applications")
(description "This package provides Basic authentication via
@file{htpasswd} files and access_token authentication in Flask
@@ -3106,7 +3106,7 @@ more.")
(build-system python-build-system)
(arguments
`(#:tests? #f)) ;tests require internet access
- (home-page "http://github.com/saghul/pycares")
+ (home-page "https://github.com/saghul/pycares")
(synopsis "Python interface for @code{c-ares}")
(description "@code{pycares} is a Python module which provides an
interface to @code{c-ares}, a C library that performs DNS requests and
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 15d9e097c5..e1e3870d06 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10163,7 +10163,7 @@ visual (yet text based) progress to long running operations.")
(base32
"1zvf6zs5hzrc03p9nfs4p16vhilqikycvv1yk0pxn8s07fdhvzji"))))
(build-system python-build-system)
- (home-page "http://github.com/germangh/python-progressbar")
+ (home-page "https://github.com/germangh/python-progressbar")
(synopsis "Text progress bar library for Python")
(description
"This package provides a text progress bar library for Python. This
@@ -16426,7 +16426,7 @@ files, and Makefiles.")
(invoke "py.test"))))))
(native-inputs
`(("python-pytest" ,python-pytest)))
- (home-page "http://github.com/Suor/whatever")
+ (home-page "https://github.com/Suor/whatever")
(synopsis "Make anonymous functions by partial application of operators")
(description "@code{whatever} provides an easy way to make anonymous
functions by partial application of operators.")
@@ -16458,7 +16458,7 @@ functions by partial application of operators.")
(native-inputs
`(("python-pytest" ,python-pytest)
("python-whatever" ,python-whatever)))
- (home-page "http://github.com/Suor/funcy")
+ (home-page "https://github.com/Suor/funcy")
(synopsis "Functional tools")
(description "@code{funcy} is a library that provides functional tools.
Examples are:
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 8f48c3eba8..d3d27f70b2 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -2458,7 +2458,7 @@ Ruby Gems.")
(synopsis "Ruby module is for reading and writing zip files")
(description
"The rubyzip module provides ways to read from and create zip files.")
- (home-page "http://github.com/rubyzip/rubyzip")
+ (home-page "https://github.com/rubyzip/rubyzip")
(license license:bsd-2)))
(define-public ruby-simplecov-html
@@ -4758,7 +4758,7 @@ file or directories are modified.")
(package
(name "ruby-spinach")
(version "0.11.0")
- (home-page "http://github.com/codegram/spinach")
+ (home-page "https://github.com/codegram/spinach")
(source (origin
(method url-fetch)
(uri (rubygems-uri "spinach" version))
@@ -6630,7 +6630,7 @@ It is intended be used by all Cucumber implementations to parse
(package
(name "ruby-gherkin-ruby")
(version "0.3.2")
- (home-page "http://github.com/codegram/gherkin-ruby")
+ (home-page "https://github.com/codegram/gherkin-ruby")
(source (origin
(method url-fetch)
(uri (rubygems-uri "gherkin-ruby" version))
@@ -8855,7 +8855,7 @@ integrates other mathematical standard libraries. Prior to Ruby 2.5,
(description
"This gem is a port of the rails 'rake stats' method so it can be made
more robust and work for non rails projects.")
- (home-page "http://github.com/danmayer/code_statistics")
+ (home-page "https://github.com/danmayer/code_statistics")
(license license:expat)))
(define-public ruby-rubypants
@@ -9057,7 +9057,7 @@ RFC 3987, and RFC 6570 (level 4), providing support for IRIs and URI templates."
"This package extends the @code{String} class and adds a
@code{ColorizedString} with methods to set text color, background color,
and text effects.")
- (home-page "http://github.com/fazibear/colorize")
+ (home-page "https://github.com/fazibear/colorize")
(license license:gpl2+)))
(define-public ruby-colorator
@@ -10602,7 +10602,7 @@ which snapshots to consider and what files to include.")
(package
(name "ruby-wwtd")
(version "1.4.1")
- (home-page "http://github.com/grosser/wwtd")
+ (home-page "https://github.com/grosser/wwtd")
(source (origin
(method git-fetch)
(uri (git-reference