summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJesse Gibbons <jgibbons2357+guix@gmail.com>2020-04-05 20:47:02 -0600
committerOleg Pykhalov <go.wigust@gmail.com>2020-07-28 21:13:27 +0300
commit6fba1f4ded933134afb9ef1d0c03848ce6cabceb (patch)
treea413db6539f1a8ced4358b6f6214b573e1c64719 /gnu/packages
parent6a14917a16d3f629727960a9b620aa5455d963c3 (diff)
downloadguix-patches-6fba1f4ded933134afb9ef1d0c03848ce6cabceb.tar
guix-patches-6fba1f4ded933134afb9ef1d0c03848ce6cabceb.tar.gz
gnu: knights: Fix build.
* gnu/packages/games.scm (knights)[arguments]<#:make-flags>: Add "CXXFLAGS=-lpthread". Signed-off-by: Oleg Pykhalov <go.wigust@gmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/games.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 91e4861680..f7753352d6 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -1367,7 +1367,8 @@ built-in level editor.")
(build-system gnu-build-system)
(arguments
'(#:make-flags
- (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ "CXXFLAGS=-lpthread")
#:phases
(modify-phases %standard-phases
;; No configure script.