summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2022-04-08 15:22:51 +0200
committerLudovic Courtès <ludo@gnu.org>2022-04-11 11:56:21 +0200
commit6f8ae2b2b9fbe851322669875759c647b4332c00 (patch)
tree2e2d883a18d900d07a930610b49deca3ff777a33 /gnu/packages
parenta703b1d9c5607528515d91936e576c7c85365416 (diff)
downloadguix-patches-6f8ae2b2b9fbe851322669875759c647b4332c00.tar
guix-patches-6f8ae2b2b9fbe851322669875759c647b4332c00.tar.gz
gnu: Add ocaml-ppx-fixed-literal.
* gnu/packages/ocaml.scm (ocaml-ppx-fixed-literal): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ocaml.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index a5f57fe36f..67902f58b3 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5954,6 +5954,31 @@ context such as function arguments.")
to record their startup time.")
(license license:expat)))
+(define-public ocaml-ppx-fixed-literal
+ (package
+ (name "ocaml-ppx-fixed-literal")
+ (version "0.14.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/janestreet/ppx_fixed_literal")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0s7rb4dhz4ibhh42a9sfxjj3zbwfyfmaihr92hpdv5j9xqn3n8mi"))))
+ (build-system dune-build-system)
+ (arguments
+ `(#:tests? #f)); no tests
+ (propagated-inputs (list ocaml-base ocaml-ppxlib))
+ (properties `((upstream-name . "ppx_fixed_literal")))
+ (home-page "https://github.com/janestreet/ppx_fixed_literal")
+ (synopsis "Simpler notation for fixed point literals")
+ (description
+ "@samp{ppx-fixed-literal} is a ppx rewriter that rewrites fixed point
+literal of the form 1.0v to conversion functions currently in scope.")
+ (license license:expat)))
+
(define-public ocaml-ppx-optional
(package
(name "ocaml-ppx-optional")