summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-09-01 10:16:32 +0200
committerLudovic Courtès <ludo@gnu.org>2015-09-01 14:18:38 +0200
commit6e3fdbbe264b2a233f32f521e2547e4b6175578b (patch)
tree4aaaf68f1119724c1212f259aea3d1889ac1e0bd /gnu/packages
parent1defd8cd2e4efe3fa2c5532d6e560dfc37e44820 (diff)
downloadguix-patches-6e3fdbbe264b2a233f32f521e2547e4b6175578b.tar
guix-patches-6e3fdbbe264b2a233f32f521e2547e4b6175578b.tar.gz
gnu: Add emacs-flycheck.
* gnu/packages/emacs.scm (flycheck): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 7bb302c49f..57d45c22b3 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -534,6 +534,34 @@ inside body is let-bound to their cdrs in the alist. Only those present in
the body are let-bound and this search is done at compile time.")
(license license:gpl3+)))
+(define-public flycheck
+ (package
+ (name "emacs-flycheck")
+ (version "20150831.1343")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://melpa.org/packages/flycheck-"
+ version ".tar"))
+ (sha256
+ (base32
+ "0a0iyvki62rqi24dbrcdq3i1wdygdi350gcjsfrfr6fz8fasz42l"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-dash" ,emacs-dash)
+ ("emacs-let-alist" ,let-alist)))
+ (home-page "https://www.flycheck.org")
+ (synopsis "On-the-fly syntax checking")
+ (description
+ "This package provides on-the-fly syntax checking for GNU Emacs. It is a
+replacement for the older Flymake extension which is part of GNU Emacs, with
+many improvements and additional features.
+
+Flycheck provides fully-automatic, fail-safe, on-the-fly background syntax
+checking for over 30 programming and markup languages with more than 70
+different tools. It highlights errors and warnings inline in the buffer, and
+provides an optional IDE-like error list.")
+ (license license:gpl3+))) ;+GFDLv1.3+ for the manual
+
;;;
;;; Web browsing.