summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2021-04-26 17:09:42 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2021-04-26 17:09:42 +0200
commit6cd8361e78da17a300b1c88c1164ce86a0f223f7 (patch)
treea1d590ee47feed6fd11c18e4fbedd13077244170 /gnu/packages
parentf365d48909156ad754a2ade45375f45b54b06bbc (diff)
downloadguix-patches-6cd8361e78da17a300b1c88c1164ce86a0f223f7.tar
guix-patches-6cd8361e78da17a300b1c88c1164ce86a0f223f7.tar.gz
gnu: Add cl-qprint.
* gnu/packages/lisp-xyz.scm (cl-qprint, ecl-cl-qprint, sbcl-cl-qprint): New variables.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/lisp-xyz.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index efb25f9678..d37742c865 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -16132,3 +16132,34 @@ color palette for a GUI or web page.")
(define-public cl-simple-rgb
(sbcl-package->cl-source-package sbcl-simple-rgb))
+
+(define-public sbcl-cl-qprint
+ (let ((commit "bfe398551cbfb7ca84a9ba59a26a1116ac5c06eb")
+ (revision "1"))
+ (package
+ (name "sbcl-cl-qprint")
+ (version (git-version "0.9.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/eugeneia/cl-qprint/")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "099h0rrdzxnlmn8avi72mg2dl0kccp7w01b2p9nwyy4b8yr32cir"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("flexi-streams" ,sbcl-flexi-streams)))
+ (home-page "https://github.com/eugeneia/cl-qprint/")
+ (synopsis "Implementation of the quoted-printable encoding")
+ (description
+ "This Common Lisp library implements the quoted-printable encoding as
+described in RFC 2045 (see @url{http://tools.ietf.org/html/rfc2045}).")
+ (license license:lgpl2.1))))
+
+(define-public ecl-cl-qprint
+ (sbcl-package->ecl-package sbcl-cl-qprint))
+
+(define-public cl-qprint
+ (sbcl-package->cl-source-package sbcl-cl-qprint))