summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-16 16:19:47 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-16 16:23:06 +0300
commit69b13cd4eaa88ad7fe1b2e6c5ceae0357eedfac2 (patch)
tree22af856167ce1137b4fa6e83fcd91395113f3929 /gnu/packages
parent7c4c781aa40c42d4cd10b8d9482199f3db345e1b (diff)
downloadguix-patches-69b13cd4eaa88ad7fe1b2e6c5ceae0357eedfac2.tar
guix-patches-69b13cd4eaa88ad7fe1b2e6c5ceae0357eedfac2.tar.gz
gnu: Add julia-zlib-jll.
* gnu/packages/julia-xyz.scm (julia-zlib-jll): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/julia-xyz.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index db3e3b846d..dd5ee91724 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2020, 2021 Nicolò Balzarotti <nicolo@nixo.xyz>
;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
+;;; Copyright © 2021 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -22,6 +23,7 @@
#:use-module (guix packages)
#:use-module (guix git-download)
#:use-module (guix build-system julia)
+ #:use-module (gnu packages compression)
#:use-module (gnu packages gcc)
#:use-module (gnu packages maths)
#:use-module (gnu packages tls)
@@ -1286,6 +1288,45 @@ working with @acronym{URIs,Uniform Resource Identifiers}, as defined in RFC
system.")
(license license:expat)))
+(define-public julia-zlib-jll
+ (package
+ (name "julia-zlib-jll")
+ (version "1.2.12+1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaBinaryWrappers/Zlib_jll.jl")
+ (commit (string-append "Zlib-v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "05ih0haqapkzr40swvq63cafnqlc4yp6yfa1wvdyq8v3n4kxhfqa"))))
+ (build-system julia-build-system)
+ (arguments
+ '(#:tests? #f ; no runtests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'override-binary-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (map
+ (lambda (wrapper)
+ (substitute* wrapper
+ (("generate_wrapper_header.*")
+ (string-append
+ "generate_wrapper_header(\"Zlib\", \""
+ (assoc-ref inputs "zlib") "\")\n"))))
+ ;; There's a Julia file for each platform, override them all
+ (find-files "src/wrappers/" "\\.jl$")))))))
+ (inputs
+ `(("zlib" ,zlib)))
+ (propagated-inputs
+ `(("julia-jllwrappers" ,julia-jllwrappers)))
+ (home-page "https://github.com/JuliaBinaryWrappers/Zlib_jll.jl")
+ (synopsis "Zlib library wrappers")
+ (description "This package provides a wrapper for Zlib.")
+ (license license:expat)))
+
(define-public julia-zygoterules
(package
(name "julia-zygoterules")