summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-06-02 13:29:52 +0200
committerLudovic Courtès <ludo@gnu.org>2016-06-05 00:05:38 +0200
commit698bd29799089c84bc2aa2c5f40e61eba83dd0b8 (patch)
tree1ab84a615f541fba557bacf842a77d7ef2650c5f /gnu/packages
parent1713c37f835a0566a47d76d2379b2d0b12c0b548 (diff)
downloadguix-patches-698bd29799089c84bc2aa2c5f40e61eba83dd0b8.tar
guix-patches-698bd29799089c84bc2aa2c5f40e61eba83dd0b8.tar.gz
gnu: Use full SHA1 commit ids.
* gnu/packages/bioinformatics.scm (pbtranscript-tofu, mosaik, smithlab-cpp, piranha): Use full SHA1 commit ids. * gnu/packages/ci.scm (hydra): Likewise. * gnu/packages/compression.scm (sfarkxtc): Likewise. * gnu/packages/emacs.scm (emacs-ob-ipython): Likewise. * gnu/packages/games.scm (mars, emulation-station): Likewise. * gnu/packages/gnunet.scm (guile-gnunet): Likewise. * gnu/packages/music.scm (non-sequencer): Likewise. * gnu/packages/version-control.scm (git-flow, git-test-sequence): Likewise. * gnu/packages/xorg.scm (xf86-video-intel): Likewise. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioinformatics.scm12
-rw-r--r--gnu/packages/ci.scm4
-rw-r--r--gnu/packages/compression.scm7
-rw-r--r--gnu/packages/emacs.scm2
-rw-r--r--gnu/packages/games.scm59
-rw-r--r--gnu/packages/gnunet.scm4
-rw-r--r--gnu/packages/music.scm4
-rw-r--r--gnu/packages/version-control.scm6
-rw-r--r--gnu/packages/xorg.scm4
9 files changed, 52 insertions, 50 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 22bd81c75b..6a90aa9456 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2670,10 +2670,10 @@ the phenotype as it models the data.")
(license license:asl2.0)))
(define-public pbtranscript-tofu
- (let ((commit "8f5467fe6"))
+ (let ((commit "8f5467fe6a4472bcfb4226c8720993c8507adfe4"))
(package
(name "pbtranscript-tofu")
- (version (string-append "2.2.3." commit))
+ (version (string-append "2.2.3." (string-take commit 7)))
(source (origin
(method git-fetch)
(uri (git-reference
@@ -3009,7 +3009,7 @@ viewer.")
(delete 'configure))))))))
(define-public mosaik
- (let ((commit "5c25216d"))
+ (let ((commit "5c25216d3522d6a33e53875cd76a6d65001e4e67"))
(package
(name "mosaik")
(version "2.2.30")
@@ -3259,10 +3259,10 @@ subsequent visualization, annotation and storage of results.")
(define-public smithlab-cpp
(let ((revision "1")
- (commit "728a097"))
+ (commit "728a097bec88c6f4b8528b685932049e660eff2e"))
(package
(name "smithlab-cpp")
- (version (string-append "0." revision "." commit))
+ (version (string-append "0." revision "." (string-take commit 7)))
(source (origin
(method git-fetch)
(uri (git-reference
@@ -5169,7 +5169,7 @@ libraries for systems that do not have these available via other means.")
("samtools" ,samtools-0.1)
("gsl" ,gsl)
("smithlab-cpp"
- ,(let ((commit "3723e2d"))
+ ,(let ((commit "3723e2db438c51501d0423429ff396c3035ba46a"))
(origin
(method git-fetch)
(uri (git-reference
diff --git a/gnu/packages/ci.scm b/gnu/packages/ci.scm
index be18ebd29f..e0ff873b3e 100644
--- a/gnu/packages/ci.scm
+++ b/gnu/packages/ci.scm
@@ -39,10 +39,10 @@
#:use-module (guix build-system gnu))
(define-public hydra
- (let ((commit "4c0e3e4"))
+ (let ((commit "4c0e3e47034545ad3e9e86dd069138bcebb8ccee"))
(package
(name "hydra")
- (version (string-append "20150407." commit))
+ (version (string-append "20150407." (string-take commit 7)))
(source (origin
(method git-fetch)
(uri (git-reference
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 5746ca3e03..dd107487fb 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -443,16 +443,17 @@ with the sfArk algorithm.")
(license license:gpl3+)))
(define-public sfarkxtc
+ (let ((commit "b5e0a2ba3921f019d74d4b92bd31c36dd19d2cf1"))
(package
(name "sfarkxtc")
- (version "b5e0a2ba39")
+ (version (string-take commit 10))
(source (origin
;; There are no release tarballs, so we just fetch the latest
;; commit at this time.
(method git-fetch)
(uri (git-reference
(url "https://github.com/raboof/sfarkxtc.git")
- (commit version)))
+ (commit commit)))
(sha256
(base32
"0f5x6i46qfl6ry21s7g2p4sd4b2r1g4fb03yqi2vv4kq3saryhvj"))))
@@ -473,7 +474,7 @@ with the sfArk algorithm.")
(synopsis "Basic sfArk decompressor")
(description "SfArk extractor converts SoundFonts in the compressed legacy
sfArk file format to the uncompressed sf2 format.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public libmspack
(package
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 797041f05d..07b4255adb 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1238,7 +1238,7 @@ files and directories.")
(source (origin
(method git-fetch)
(uri (git-reference
- (commit "8807064693")
+ (commit "880706469338ab59b5bb7dbe8460016f89755364")
(url "https://github.com/gregsexton/ob-ipython.git")))
(sha256
(base32
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index e552d09efa..368f09632c 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -590,11 +590,11 @@ for common mesh file formats, and collision detection.")
;; The latest release on SourceForge relies on an unreleased version of SFML
;; with a different API, so we take the latest version from the official
;; repository on Github.
- (let ((commit "c855d04409")
+ (let ((commit "c855d044094a1d92317e38935d81ba938946132e")
(revision "1"))
(package
(name "mars")
- (version (string-append "0.7.5." revision "." commit ))
+ (version (string-append "0.7.5." revision "." (string-take commit 7) ))
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1833,36 +1833,37 @@ emulation community. It provides highly accurate emulation.")
(license license:gpl2+)))
(define-public emulation-station
- (package
- (name "emulation-station")
- (version "2.0.1")
- (source (origin
- (method git-fetch) ; no tarball available
- (uri (git-reference
- (url "https://github.com/Aloshi/EmulationStation.git")
- (commit "646bede"))) ; no version tag
- (sha256
- (base32
- "0cm0sq2wri2l9cvab1l0g02za59q7klj0h3p028vr96n6njj4w9v"))))
- (build-system cmake-build-system)
- (arguments
- '(#:tests? #f)) ; no tests
- (inputs
- `(("alsa-lib" ,alsa-lib)
- ("boost" ,boost)
- ("curl" ,curl)
- ("eigin" ,eigen)
- ("freeimage" ,freeimage)
- ("freetype" ,freetype)
- ("mesa" ,mesa)
- ("sdl2" ,sdl2)))
- (synopsis "Video game console emulator front-end")
- (description "EmulationStation provides a graphical front-end to a large
+ (let ((commit "646bede3d9ec0acf0ae378415edac136774a66c5"))
+ (package
+ (name "emulation-station")
+ (version "2.0.1")
+ (source (origin
+ (method git-fetch) ; no tarball available
+ (uri (git-reference
+ (url "https://github.com/Aloshi/EmulationStation.git")
+ (commit commit))) ; no version tag
+ (sha256
+ (base32
+ "0cm0sq2wri2l9cvab1l0g02za59q7klj0h3p028vr96n6njj4w9v"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:tests? #f)) ; no tests
+ (inputs
+ `(("alsa-lib" ,alsa-lib)
+ ("boost" ,boost)
+ ("curl" ,curl)
+ ("eigin" ,eigen)
+ ("freeimage" ,freeimage)
+ ("freetype" ,freetype)
+ ("mesa" ,mesa)
+ ("sdl2" ,sdl2)))
+ (synopsis "Video game console emulator front-end")
+ (description "EmulationStation provides a graphical front-end to a large
number of video game console emulators. It features an interface that is
usable with any game controller that has at least 4 buttons, theming support,
and a game metadata scraper.")
- (home-page "http://www.emulationstation.org")
- (license license:expat)))
+ (home-page "http://www.emulationstation.org")
+ (license license:expat))))
(define openttd-engine
(package
diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index b5a2685f65..0819c485cb 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -266,10 +266,10 @@ privacy-preserving, decentralized public key infrastructure.")
(home-page "https://gnunet.org/")))
(define-public guile-gnunet ;GSoC 2015!
- (let ((commit "383eac2"))
+ (let ((commit "383eac2aab175d8d9ea5315c2f1c8a5055c76a52"))
(package
(name "guile-gnunet")
- (version (string-append "0.0." commit))
+ (version (string-append "0.0." (string-take commit 7)))
(source (origin
(method git-fetch)
(uri (git-reference
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 50f9a70810..d491aa605e 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -437,10 +437,10 @@ Guile.")
(define-public non-sequencer
;; The latest tagged release is three years old and uses a custom build
;; system, so we take the last commit affecting the "sequencer" directory.
- (let ((commit "1d9bd576"))
+ (let ((commit "1d9bd576f6bf7ea240af5f7a60260592750af0dd"))
(package
(name "non-sequencer")
- (version (string-append "1.9.5-" commit))
+ (version (string-append "1.9.5-" (string-take commit 7)))
(source (origin
(method git-fetch)
(uri (git-reference
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 26cd11acde..346f9753a8 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -479,7 +479,7 @@ will work.")
(method git-fetch)
(uri (git-reference
(url "https://github.com/nvie/gitflow/")
- (commit "15aab26")))
+ (commit "15aab26490facf285acef56cb5d61025eacb3a69")))
(sha256
(base32
"01fs97q76fdfnvmrh2cyjhywcs3pykf1dg58sy0frflnsdzs6prx"))))
@@ -513,10 +513,10 @@ lot easier.")
(license bsd-2)))
(define-public git-test-sequence
- (let ((commit "48e5a2f"))
+ (let ((commit "48e5a2f5a13a5f30452647237e23362b459b9c76"))
(package
(name "git-test-sequence")
- (version (string-append "20140312." commit))
+ (version (string-append "20140312." (string-take commit 7)))
(source (origin
(method git-fetch)
(uri (git-reference
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index fd933e36a7..46f0f6ec99 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -2810,10 +2810,10 @@ X server.")
(define-public xf86-video-intel
- (let ((commit "d167280"))
+ (let ((commit "d1672806a5222f00dcc2eb24ccddd03f727f71bc"))
(package
(name "xf86-video-intel")
- (version (string-append "2.99.917-1-" commit))
+ (version (string-append "2.99.917-1-" (string-take commit 7)))
(source
(origin
;; there's no current tarball